Bug 509373 - configtest returns 0 all the time
configtest returns 0 all the time
Status: CLOSED DUPLICATE of bug 530214
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: bind (Show other bugs)
5.4
All Linux
low Severity low
: rc
: ---
Assigned To: Adam Tkac
BaseOS QE
:
Depends On: 496495
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-02 10:13 EDT by Matěj Šusta
Modified: 2013-04-30 19:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 496495
Environment:
Last Closed: 2009-10-26 07:34:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Šusta 2009-07-02 10:13:16 EDT
+++ This bug was initially created as a clone of Bug #496495 +++

Description of problem:
The 'configtest' option of the bind initscript does not complain if named.conf uses an un-defined ACL, despite the fact that this prevents the nameserver from starting. 

Version-Release number of selected component (if applicable):
bind-9.3.4-10.P1.el5

How reproducible:
Always

Steps to Reproduce:
1. Add to named.conf a reference to a non-existent ACl, eg, "allow-query {foo;};"
2. Run "service named configtest". No error should be reported.
3. Run "service named restart". Startup should fail with something like the following in /var/log/messages: "/etc/named.conf:29: undefined ACL 'foo'"
  
Actual results:
No error reported by configtest

Expected results:
Error reported by configtest




command "service named configtest" is returning 0 even if testfiles failed in check.
Comment 2 Adam Tkac 2009-10-26 07:34:37 EDT

*** This bug has been marked as a duplicate of bug 530214 ***

Note You need to log in before you can comment on or make changes to this bug.