Bug 50938 - Apache Children Fail to Respawn after Multiple SIGHUP's
Summary: Apache Children Fail to Respawn after Multiple SIGHUP's
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache
Version: 7.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-05 07:22 UTC by Ken Barber
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-09-21 10:41:28 UTC


Attachments (Terms of Use)

Description Ken Barber 2001-08-05 07:22:53 UTC
Description of Problem:

After a multiple amount of SIGHUP's - the Apache master process fails to 
fork children.

How Reproducible:

Send 5-6 SIGHUP signals to Apache master process

Steps to Reproduce:
1. Find Apache master process with pstree command
2. Send SIGHUP signal five or six times 
3. Test port 80 connections, or view pstree to see if children have 
respawned

Actual Results:

The apache server fails to respond to HTTP requests. Subsequent SIGHUP's 
have no result. The server requires a restart.

Expected Results:

Restart of server.

Additional Information:
	
For my system information - you may take a look at RHN for 
venus.underscoresolutions.com.au or mail me. This bug existed in even the 
standard version of Apache 1.3.19 from the redhat ftp site.

Comment 1 Ken Barber 2001-12-23 21:24:22 UTC
This bug seems to be fixed in the rpm 'apache-1.3.22-2'. This is a 7.2 package
however. I am not aware if this bug is now repaired in the older 7.1.

Comment 2 Joe Orton 2004-09-21 10:41:28 UTC
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.


Comment 3 David Juran 2004-09-21 19:35:06 UTC
This bug is still reproducable on httpd-2.0.50-2.1 in FC2. Please reopen.


Note You need to log in before you can comment on or make changes to this bug.