Bug 509409 - Packages pushed to an RHN Proxy via rhn_package_manager do not report name of package upon corresponding Satellite's package details overview page
Packages pushed to an RHN Proxy via rhn_package_manager do not report name of...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Brad Buckingham
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-07-02 12:36 EDT by Steve Salevan
Modified: 2009-09-10 16:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:38:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nvrea.rpm.rpm (132.38 KB, image/png)
2009-07-17 00:05 EDT, Brad Buckingham
no flags Details

  None (edit)
Description Steve Salevan 2009-07-02 12:36:24 EDT
Description of problem:
If a user uploads a package to an RHN Proxy via rhn_package_manager and then visits the package details page for it upon the Proxy's corresponding Satellite, located here:

/rhn/software/packages/Details.do?pid=<pid>

the name of the package will not show up upon the page, as in the attached screenshot.

Version-Release number of selected component (if applicable):
530, 6/25 build

How reproducible:
Always

Steps to Reproduce:
1. Push a package to a proxy via rhn_package_manager
2. Visit the package details page for this package
  
Actual results:
As in the attached screenshot

Expected results:
Name of package appears on page

Additional info:
Comment 3 Shannon Hughes 2009-07-09 16:32:10 EDT
fixed the display of packages pushed by rhn_package_manager. we were constructing the name from the file path which does not work for proxy pushes since its not on the sat. 

9910fee57f7d7d263ca27ebf963fcc80cb20e461
Comment 4 Shannon Hughes 2009-07-10 08:53:59 EDT
mass move to onqa
Comment 5 Brad Buckingham 2009-07-17 00:05:37 EDT
Created attachment 354088 [details]
nvrea.rpm.rpm

package name contains redundant .rpm
Comment 6 Brad Buckingham 2009-07-17 00:07:21 EDT
Satellite-5.3.0-RHEL4-re20090714.0-i386-embedded-oracle.iso

The package name is now included on the page; however, it is nvrea.rpm.rpm vs nvrea.rpm.  See attachment.
Comment 7 Shannon Hughes 2009-07-17 12:11:05 EDT
ended up just rewriting the method. it was not handling epoch either.
Comment 8 Brad Buckingham 2009-07-22 13:45:43 EDT
Satellite-5.3.0-RHEL5=re20090721.0-i386-embedded-oracle.iso

Pushed a few packages to the proxy using rhn_package_manager.  Verified that the package details in the Satellite UI now show the name correctly.
Comment 9 Tomas Lestach 2009-08-24 10:19:16 EDT
1. pushed several packages to proxy using rhn_packgae_manager
2. package details page shows correctly packgae name of every pushed package

Stage validated -> RELEASE_PENDING
Comment 10 Brandon Perkins 2009-09-10 16:38:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.