Bug 509428 - X fails to start, segfaults
X fails to start, segfaults
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-02 14:12 EDT by Pete Zaitcev
Modified: 2012-08-08 18:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-09 21:11:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (13.75 KB, text/plain)
2009-07-02 14:13 EDT, Pete Zaitcev
no flags Details
dmesg (42.47 KB, application/octet-stream)
2009-08-05 14:46 EDT, Pete Zaitcev
no flags Details

  None (edit)
Description Pete Zaitcev 2009-07-02 14:12:14 EDT
Description of problem:

After an update yesterday, X fails to start in the morning with a segfault
at address 0x3c8.

Version-Release number of selected component (if applicable):

xorg-x11-drv-intel-2.8.0-0.1.fc12.x86_64
kernel-2.6.31-0.35.rc1.git5.fc12.x86_64

How reproducible:

Synchronous

Steps to Reproduce:
1. Remove xorg.conf
2. startx
  
Actual results:

Segfault

Expected results:

Working X

Additional info:

Here's the backtrace:

0: /usr/bin/X(xorg_backtrace+0x28) [0x45f178]
1: /usr/bin/X [0x4627c9]
2: /lib64/libc.so.6 [0x3cba633370]
3: /usr/lib64/xorg/modules/drivers/intel_drv.so [0x7faab0090b36]
4: /usr/bin/X(xf86DeleteScreen+0x80) [0x475da0]
5: /usr/bin/X(InitOutput+0x57a) [0x4707ca]
6: /usr/bin/X [0x42272a]
7: /lib64/libc.so.6(__libc_start_main+0xfd) [0x3cba61ea2d]
8: /usr/bin/X [0x422479]
Segmentation fault at address 0x3c8

Since this is a Havendale box (e.g. not supported), it usually uses VESA.
Obviously yesterday's update switched it from vesa to intel, with the
result above. Actually I welcome this, because vesa gets wrong resolution.

David Airlie told me that Kristian is supposed to fix Auburndale/Havendale,
but krh blogged a few days ago that he had a son. And now this!

Coincidentially, forcing vesa with xorg.conf does not work either,
because the same update broke vesa as well (segfault in pixman).
What a scew-up.
Comment 1 Pete Zaitcev 2009-07-02 14:13:32 EDT
Created attachment 350321 [details]
Xorg.0.log
Comment 2 Pete Zaitcev 2009-07-23 23:44:35 EDT
Updated to xorg-x11-drv-intel-2.8.0-0.3.fc12.x86_64, no more crash at
bogus MMIO access with the offset of VGA I/O register, but no work either.
Now it looks like this:

(EE) open /dev/fb0: No such file or directory
FATAL: Module fbcon not found
(EE) intel(0): No modes.

Evidently it must have KMS to function, but that is missing.
When kernel boots, it stays in text mode. Version:
kernel-2.6.31-0.81.rc3.git4.fc12.x86_64
Comment 3 Pete Zaitcev 2009-07-27 23:13:29 EDT
kernel-2.6.31-0.94.rc4.fc12.x86_64 came out, has changelog from Kristian
about "Add drm-page-flip.patch", but no help to the lack of /dev/fb0.
Comment 4 Pete Zaitcev 2009-08-05 14:27:54 EDT
This may be fixed in kernel-2.6.31-0.125.rc5.git2.fc12.x86_64. The kernel
goes into framebuffer mode on boot. Unfortunately, startx hits bug 515785,
so I cannot tell for sure if X works. I'll close once I know that it works.
Comment 5 Pete Zaitcev 2009-08-05 14:46:16 EDT
Created attachment 356403 [details]
dmesg

Note that i915 still complains about being unable to read the EDID.
This is possibly because I have a DisplayLink connector. Nonetheless,
the resolution appears correct visually. Maybe the fb preserves the
old modes, I dunno.
Comment 6 Pete Zaitcev 2009-08-09 21:11:48 EDT
Fixed with:
xorg-x11-drv-intel-2.8.0-3.fc12.x86_64
xorg-x11-server-Xorg-1.6.99-27.20090804.fc12.x86_64

I still see some issues, like not restoring display if DPMS strikes,
but that's for a different bug. Closing.

Note You need to log in before you can comment on or make changes to this bug.