Bug 50945 - System locks hard when starting window manager
Summary: System locks hard when starting window manager
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: roswell
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-05 11:42 UTC by Bernd Bartmann
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-11 16:05:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86-4 Config File (3.69 KB, patch)
2001-08-08 18:43 UTC, Bernd Bartmann
no flags Details | Diff
XFree-4 log file found after crash and reboot (20.48 KB, patch)
2001-08-08 18:44 UTC, Bernd Bartmann
no flags Details | Diff
rpm -qa | sort (21.37 KB, patch)
2001-08-08 18:45 UTC, Bernd Bartmann
no flags Details | Diff

Description Bernd Bartmann 2001-08-05 11:42:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [de] (X11; U; Linux 2.2.19bb01-ide+raid+ipsec
i686)

Description of problem:
After logging in to GNOME or KDE my system locks hard when trying to start
the window manager.

How reproducible:
Always

Steps to Reproduce:
1. Log in GNOME or KDE
2. Watch the icons and text on the KDE/GNOME splash screen
3.
	

Actual Results:  When the splash screen says "Starting window manager" the
system locks hard.

Additional info:

I can4t find any messages in /var/log/messages or in the X11 error log file
after reboot.
Some informations about my hardware: Matrox Millenium G200 AGP, Logitech
IFeel Mouse, K6-2 333, 256 MB memory, mainboard with SIS chipset.

Comment 1 Glen Foster 2001-08-06 22:42:12 UTC
We (Red Hat) should try to fix this for the next release.

Comment 2 Mike A. Harris 2001-08-08 16:26:57 UTC
Attach X config and X log as separate file attachments using the
link below.  Then I can proceed to look at this.

Comment 3 Mike A. Harris 2001-08-08 16:40:48 UTC
Can you also send:
uname -a
rpm -qa |sort    (file attachment)

Comment 4 Bernd Bartmann 2001-08-08 18:43:16 UTC
Created attachment 26854 [details]
XFree86-4 Config File

Comment 5 Bernd Bartmann 2001-08-08 18:44:24 UTC
Created attachment 26855 [details]
XFree-4 log file found after crash and reboot

Comment 6 Bernd Bartmann 2001-08-08 18:45:07 UTC
Created attachment 26856 [details]
rpm -qa | sort

Comment 7 Bernd Bartmann 2001-08-08 18:46:19 UTC
I have attached the files you requested and here is uname -a:
Linux deanna 2.4.6-3.1 #1 Tue Jul 24 16:03:09 EDT 2001 i586 unknown

Comment 8 Bernd Bartmann 2001-08-22 09:08:56 UTC
The problem still exists on ROSWELL Beta 2.

Comment 9 Mike A. Harris 2002-02-11 14:31:22 UTC
This problem is believed to be fixed now with 4.1.0-15 at least, possibly
with the 4.1.0-3 released with Enigma also.  I believe drm would not
load because of an agpgart issue which was fixed.

Can you confirm wether this bug is still relevant, so I can close it
or troubleshoot it further?

Thanks.

Comment 10 Bernd Bartmann 2002-02-11 16:05:28 UTC
Seems to be ok now. Now running RedHat 7.2 with all current updates as of today.

Comment 11 Mike A. Harris 2002-02-11 18:01:12 UTC
thanks


Note You need to log in before you can comment on or make changes to this bug.