Bug 509456 - Advanced Search for Hardware Devices / Description returns results not displayed on the system's Details / Hardware page
Advanced Search for Hardware Devices / Description returns results not displa...
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2009-07-02 17:14 EDT by John Sefler
Modified: 2014-07-04 09:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-04 09:24:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Searched for "Intel" with field Hardware Devices / "Description" (166.94 KB, application/octet-stream)
2009-07-02 17:14 EDT, John Sefler
no flags Details
Top half of Details / Hardware page of system. (180.04 KB, image/png)
2009-07-02 17:15 EDT, John Sefler
no flags Details
Bottom half of Details / Hardware page of system. (155.98 KB, image/png)
2009-07-02 17:16 EDT, John Sefler
no flags Details

  None (edit)
Description John Sefler 2009-07-02 17:14:02 EDT
Created attachment 350350 [details]
Searched for "Intel" with field Hardware Devices / "Description"

Description of problem:
When doing an Advanced Search with a 'Field to Search:' set to 'Hardware Devices / Description', the results from the search display a 'Description' field that does not appear in any of the devices displayed on the system's "Details/Hardware" page.

I have attached a few screenshots:
1. A screen shot that shows the search results for systems with a 'Hardware Devices / Description' of "Intel".  (My search string was "Intel")
The results of the search show two systems with a near matching Description of "Networking Interface".    The near match to Intel are the first 4 letters in Interface.  That's fine.  The problem is in the next two screen shots:
2.3. Screen shots of the top and bottom of the "Details/Hardware" page of a system in the search results.  Notice that there are no devices displayed that contain a description of "Networking Interface".  So the defect is: where did the search results come from?  Apparently there may be a device that is not being displayed on this page whose description is "Networking Interface".  Therefore it should also be displayed on the hardware page.
Comment 1 John Sefler 2009-07-02 17:15:48 EDT
Created attachment 350351 [details]
Top half of Details / Hardware page of system.
Comment 2 John Sefler 2009-07-02 17:16:27 EDT
Created attachment 350352 [details]
Bottom half of Details / Hardware page of system.

Note You need to log in before you can comment on or make changes to this bug.