Bug 509490 - OpenIPMI and OpenIPMI-tools have incorrect default chkconfig and rpm dependencies
OpenIPMI and OpenIPMI-tools have incorrect default chkconfig and rpm dependen...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: OpenIPMI (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jan Safranek
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-02 23:54 EDT by Mark Goodwin
Modified: 2011-01-24 19:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:59:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Goodwin 2009-07-02 23:54:20 EDT
Description of problem:
The ipmievd service is chkconfig "on" by default whereas the
impi service (upon which ipmievd depends) is chkconfig "off".
Further more, the OpenIPMI-tools package does not require
the OpenIPMI package.

These two issues are customer reported against RHEL5.4-beta.
I've opened a new BZ since BZ 504161 isn't quite the same.

Version-Release number of selected component (if applicable):
[root@localhost tmp]# rpm -q OpenIPMI OpenIPMI-tools
OpenIPMI-2.0.16-4.el5
OpenIPMI-tools-2.0.16-4.el5
[root@localhost tmp]# /sbin/chkconfig --list | fgrep ipmi
ipmi           	0:off	1:off	2:off	3:off	4:off	5:off	6:off
ipmievd        	0:off	1:off	2:off	3:on	4:on	5:on	6:off
[root@localhost tmp]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5.4 Beta (Tikanga)


How reproducible:
always

Steps to Reproduce:
1. install OpenIPMI and OpenIPMI-tools
2. chkconfig --list | fgrep IPMI
3. rpm -e OpenIPMI
  
Expected results:
ipmievd should be chkconfig off by default
(or alternatively, ipmi should be chkconfig on by default)
and OpenIPMI-tools should depend on OpenIPMI
Comment 1 Mark Goodwin 2009-07-08 21:45:14 EDT
Setting NeedInfo from jsafrane@redhat.com
Comment 2 Mark Goodwin 2009-07-16 22:30:28 EDT
flagging 5.4 for consideration since we might get a lot of gss calls on this
(already have two for the 5.4 beta, see the linked IT's)
Comment 4 Jan Safranek 2009-07-17 02:48:34 EDT
(In reply to comment #0)
> Description of problem:
> The ipmievd service is chkconfig "on" by default whereas the
> impi service (upon which ipmievd depends) is chkconfig "off".

That's really a bug and needs to be fixed.

> Further more, the OpenIPMI-tools package does not require
> the OpenIPMI package.

OpenIPMI-tools does not necessarily depend on OpenIPMI, ipmievd can be configured to use other drivers. OpenIPMI is only the default one.
Comment 10 errata-xmlrpc 2009-09-02 05:59:27 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1312.html

Note You need to log in before you can comment on or make changes to this bug.