Bug 509513 - Segmentation fault in sasl_client_add_plugin
Segmentation fault in sasl_client_add_plugin
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: autofs5 (Show other bugs)
4.7
All Linux
high Severity high
: rc
: ---
Assigned To: Ian Kent
yanfu,wang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-03 04:15 EDT by Tomas Smetana
Modified: 2011-02-16 09:20 EST (History)
5 users (show)

See Also:
Fixed In Version: autofs5-5.0.1-0.rc2.110
Doc Type: Bug Fix
Doc Text:
Previously, autofs could encounter segmentation faults if it called the non-thread safe xmlCleanupParser concurrently from multiple threads. This update changes autofs to call this function only once from its main thread when the application exits.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-16 09:20:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Complete backtrace (6.88 KB, text/plain)
2009-07-03 04:16 EDT, Tomas Smetana
no flags Details
Another backtrace (7.18 KB, text/plain)
2009-07-03 04:17 EDT, Tomas Smetana
no flags Details

  None (edit)
Description Tomas Smetana 2009-07-03 04:15:10 EDT
Description of problem:
Automount segfaults while reloading maps.

Version-Release number of selected component (if applicable):
autofs5-5.0.1-0.rc2.88
autofs5-5.0.1-0.rc2.106

How reproducible:
intermittently

Steps to Reproduce:
1.  reload the maps
  
Actual results:
Jun  6 04:44:25 csl040 kernel: automount5[17905]: segfault at 0000000000000000 rip 0000002a96428466 rsp 000000004081f2a0 error 4

Expected results:
no error

Additional info:
The backtrace of the segfaulting thread looks like this:

#0  0x0000002a9642b466 in sasl_client_add_plugin () from /usr/lib64/libsasl2.so.2
#1  0x0000002a96434883 in _sasl_load_plugins () from /usr/lib64/libsasl2.so.2
#2  0x0000002a9642b6ef in sasl_client_init () from /usr/lib64/libsasl2.so.2
#3  0x0000002a95f7327f in autofs_sasl_client_init (logopt=0) at cyrus-sasl.c:955
#4  0x0000002a95f6f183 in lookup_init (mapfmt=0x2a95f7e170 "sun", argc=5, argv=0x552abf8f70, context=0x552ac02af0) at lookup_ldap.c:1264
#5  0x000000552aabb8dd in open_lookup (name=0x552abf8b50 "ldap", err_prefix=0x552aace615 "", mapfmt=0x0, argc=5, argv=0x552abf8f70) at module.c:122
#6  0x000000552aabc6fa in do_read_map (ap=0x552abf8db0, map=0x552abf8f00, age=1244752351) at lookup.c:271
#7  0x000000552aabca0b in lookup_nss_read_map (ap=0x552abf8db0, source=0x0, age=1244752351) at lookup.c:501
#8  0x000000552aabe9d0 in do_readmap (arg=Variable "arg" is not available.
) at state.c:395
#9  0x0000002a95672137 in start_thread () from /lib64/tls/libpthread.so.0
#10 0x0000002a9594e883 in clone () from /lib64/tls/libc.so.6
Comment 1 Tomas Smetana 2009-07-03 04:16:57 EDT
Created attachment 350389 [details]
Complete backtrace
Comment 2 Tomas Smetana 2009-07-03 04:17:34 EDT
Created attachment 350390 [details]
Another backtrace
Comment 3 Ian Kent 2009-07-05 23:03:28 EDT
I sent an email to the client asking him to try the current
RHEL-5 autofs package on a RHEL-5 system.

Here is a copy of what I said:

Someone else mailed me about seeing similar crashes on RHEL-5 and I
asked them to try the current RHEL-5 autofs package. He reported that
had fixed the issue but we could have a second problem. Could you also
try the current RHEL-5 U4 package on a RHEL-5 machine in case this is
already resolved. You can find it at
http://people.redhat.com/~ikent/autofs-5.0.1-0.rc2.129.

There has been an ongoing problem with the libxml2 library being
unloaded during LDAP lookups which I've had several attempts at fixing
but didn't get quite right until U4 (at least I believe it is fixed now)
so we need to check to make sure you are not seeing this same issue.

The backtraces you have provided do indicate that there may also be a
problem with libxml2 thread safely when parsing an XML documents but I
need to verify this isn't the library unload issue before adding locking
to cover that case.

I haven't started RHEL-4 U9 bug fix backporting yet so we will need to
work with RHEL-5 until I can get that done.
Comment 4 Jong Bae KO 2009-07-15 18:33:07 EDT
Hi 

Is there any update?
The customer is looking for the patch.

Thanks,
John KO
Comment 5 Ian Kent 2009-07-16 05:47:18 EDT
(In reply to comment #4)
> Hi 
> 
> Is there any update?
> The customer is looking for the patch.

If your asking if I've started work on the RHEL-4.9 bug fixes
and selective back port then that's a no, not yet. I haven't
even reviewed the RHEL-5 work and raised the necessary bugs.
I'm still working on RHEL-5.4 really. I could start by back
porting the fixes I think might fix this but ...

I don't yet know for sure if the problem is fully addressed by
the current RHEL-5 package. Where is the customer feedback on
running revision 129 on RHEL-5?

Also, there is an important correction to the RHEL-5 autofs so
we should have the customer using revision 130, which is present
on my RedHat people site at:
http://people.redhat.com/~ikent/autofs-5.0.1-0.rc2.130

Ian
Comment 9 Ian Kent 2009-11-02 02:40:17 EST
A package with the changes that are expected to fix this issue
can be found at:
http://people.redhat.com/~ikent/autofs5-5.0.1-0.rc2.109.bz509513.1/

Please test this package.

Note that this may not include all corrections that will be
included in RHEL-4.9 and, although we expect all the corrections
included in this package to be in RHEL-4.9, they have not yet
been approved for inclusion as the RHEL-4.9 release process is
not far enough along at this stage.
Comment 10 Jong Bae KO 2009-12-03 23:35:15 EST
hi lan,

The customer verified the test rpms. it works.

thanks,
JKO
Comment 12 yanfu,wang 2010-12-21 02:41:11 EST
can't reproduce it, verified autofs-5.0.1-fix-libxml2-non-thread-safe-calls.patch apply is sane, and do autofs regression also.
Comment 13 Florian Nadge 2011-01-03 11:24:35 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, autofs could encounter segmentation faults if it called the non-thread safe xmlCleanupParser concurrently from multiple threads. This update changes autofs to call this function only once from its main thread when the application exits.
Comment 14 errata-xmlrpc 2011-02-16 09:20:44 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0241.html

Note You need to log in before you can comment on or make changes to this bug.