Bug 50952 - kmail send fails
kmail send fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdenetwork (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-05 10:44 EDT by Gene Czarcinski
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-20 04:17:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2001-08-05 10:44:28 EDT
Description of Problem:
I moved my email (large and many) to a beta3 (Roswell) system.  Everything
seemed to work fine and I could recieve and filter messages.  Then I tried
to send a message ... oops, I got a popup message with:

Sending Failed:
a SMTP error occured.
Command;  MAIL
Response:  452 Out of memory
(and a bit more info)

Try again .. still fails.  Restart and reboot ... the same.

How Reproducible:
I deleted the kmail config files and ~/Mail, restarted kmail and then
proceeded to "rebuild" ~/Mail from my old (saved) files occationally trying
to send (successful) until at some point ...oops, cannot send again.

I have rebuilt 4 times with the same end result.  The "oops" point differs
each time.

Steps to Reproduce:
1. I can reproduce but this seems to be with all of my ~/Mail files
2. 
3. 

Actual Results:
Sending failed:

Expected Results:
send successful

Additional Information:
Comment 1 Gene Czarcinski 2001-08-05 12:10:22 EDT
Some additional info:

I have managed to recover but believe that this is still a bug (or undocumented
feature).

I tend to keep all sent-mail plus have a lot of clutter in my inbox (plus lots
of filered mailing lists).

The number of extra folders does not seem to make any difference.

I had 399 messages in my inbox (approx 15MB) and 1204 message in sent-mail
(almost 20 MB).

This info may make it more reproducable for developers.
Comment 2 Bernhard Rosenkraenzer 2001-08-05 12:35:55 EDT
The "452" seems to indicate this is an actual problem during the SMTP 
transmission (possibly on the server side).
If you're using a local smtp server, did you get any entries in 
/var/log/maillog?

Comment 3 Gene Czarcinski 2001-08-05 12:46:38 EDT
The smtp server is my commercial ISP (smtp-server.cox.rr.com).

The only difference between working and not working seems to be the size of
sent-mail and inbox.

I am going to run some tests to see if I can narrow it down.
Comment 4 Gene Czarcinski 2001-08-05 13:28:41 EDT
OK, I can now reproduce it at will and so should you with the following info.

1. Delete all kde and ~/Mail stuff from a users home directory.

2. login selecting kde session.

3. Start kmail and let it allocate its stuff.

4. Configure kmail filling in email address, smtp-server address, and define a
pop-server.

5. close kmail

6. start kmail and compose/send a message ... send works

7. close kmail

8. copy lots of message from some other folder (I used my seawolf mailing list
with some 9500+ messages and about 41MB).

9. delete ~/Mail/.inbox.index and ~/Mail/.inbox.index.sorted

10. start kmail

11. compose and send a message ... this fails with out-of-memory message.
Comment 5 Glen Foster 2001-08-06 18:30:22 EDT
This defect is considered SHOULD-FIX for Fairfax.
Comment 6 Ngo Than 2003-06-20 04:17:03 EDT
It's seems that'is fixed in new kde upstream 3.1 or newer, which is included in
RHL 9. It's also available on ftp.kde.org

Note You need to log in before you can comment on or make changes to this bug.