Bug 509525 - yum downloadonly utilities don't work
yum downloadonly utilities don't work
Status: CLOSED DUPLICATE of bug 506640
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-03 05:53 EDT by Liam Li
Modified: 2014-01-21 18:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-03 06:14:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liam Li 2009-07-03 05:53:32 EDT
Description of problem:

downloadonly utilities can't set attribute

Version-Release number of selected component (if applicable):
yum-3.2.23-3.fc11.noarch
yum-plugin-downloadonly-1.1.21-2.fc11.noarch
How reproducible:

Steps to Reproduce:
1.update yum to latest version ,install  yum-plugin-downloadonly, execute command:
yum install xxxx --downloadonly --downloaddir=./
will give the following output:
Loaded plugins: downloadonly, fastestmirror, refresh-packagekit
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 178, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 348, in doCommands
    self._getTs(needTsRemove)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 101, in _getTs
    self._getTsInfo(remove_only)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 112, in _getTsInfo
    pkgSack = self.pkgSack
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 649, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 491, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 232, in populateSack
    self.doSetup()
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 79, in doSetup
    self.ayum.plugins.run('postreposetup')
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 180, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/downloadonly.py", line 38, in postreposetup_hook
    repo.setAttribute('pkgdir',opts.dldir)
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 295, in setAttribute
    setattr(self, key, value)
AttributeError: can't set attribute

Actual results:


Expected results:
On f10 it works well.

Additional info:
Comment 1 Liam Li 2009-07-03 06:14:22 EDT

*** This bug has been marked as a duplicate of bug 506640 ***

Note You need to log in before you can comment on or make changes to this bug.