Bug 509547 - livecd-creator hangs making image
livecd-creator hangs making image
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-03 08:41 EDT by Steve Grubb
Modified: 2010-02-03 11:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-03 11:00:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2009-07-03 08:41:43 EDT
Description of problem:
The program creates the image on disk and just hangs doing nothing. Strace shows no activity at all, so it must be doing something in a library. ltrace doesn't show anything either.

Version-Release number of selected component (if applicable):
livecd-tools-024-1.fc11.x86_64

How reproducible:
everytime

Steps to Reproduce:
1. livecd-creator --config=fedora-livecd-desktop-en_US.ks --fslabel=Fedora-LiveCD --cache=/var/cache/live

Actual results:
This filesystem will be automatically checked every 36 mounts or
180 days, whichever comes first.  Use tune2fs -c or -i to override.
tune2fs 1.41.4 (27-Jan-2009)
Setting maximal mount count to -1
Setting interval between checks to 0 seconds
filespec_eval:  hash table stats: 12 elements, 12/65536 buckets used, longest chain length 1
Retrieving http://mirrors.kernel.org/fedora/releases/11/Everything/x86_64/os/repodata/repomd.xml ...OK
Retrieving http://mirrors.kernel.org/fedora/updates/11/x86_64/repodata/repomd.xml ...OK
No such package *debuginfo to remove

At this point its hung.
Comment 1 Jeremy Katz 2009-07-06 16:41:22 EDT
What version of yum do you have installed?  If you attach to the process with strace, is it stuck in a futex?
Comment 2 Steve Grubb 2009-07-06 17:08:28 EDT
I have yum-3.2.23-3 installed. When I attach with strace, I get no output at all. Its stuck on something and strace doesn't show it. I tried generating the image on F-10 with the same kickstart scripts and it works fine there.
Comment 3 Jeremy Katz 2009-07-07 10:45:01 EDT
It's working fine on my box which is still on F11.  Try attaching with strace earlier on and it should then show where it's hung.
Comment 4 Steve Grubb 2009-07-09 07:28:00 EDT
OK, re-ran with strace from the beginning. This is where it hung. Looks like strace did not flush its output:

open("/proc/mounts", O_RDONLY)          = 8
fstat(8, {st_mode=S_IFREG|0444, st_size=0, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f3c1ff4d000
read(8, "rootfs / rootfs rw 0 0\n/dev/root "..., 1024) = 1024
read(8, "/tmp/imgcreate-6_rrkz/install_roo"..., 1024) = 453
read(8, ""..., 1024)                    = 0
lseek(8, 0, SEEK_SET)                   = 0
read(8, "rootfs / rootfs rw 0 0\n/dev/root "..., 1024) = 1024
stat("/", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat("/tmp", {st_mode=S_IFDIR|S_ISVTX|0777, st_size=4096, ...}) = 0
stat("/var/log/audit", {st_mode=S_IFDIR|0750, st_size=4096, ...}) = 0
stat("/mnt/target", {st_mode=S_IFDIR|0775, st_size=4096, ...}) = 0
stat("/boot", {st_mode=S_IFDIR|0755, st_size=3072, ...}) = 0
read(8, "/tmp/imgcreate-6_rrkz/install_roo"..., 1024) = 453
stat("/var/tmp/imgcreate-6_rrkz/install_root/var/cache/yum", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
read(8, ""..., 1024)                    = 0
lseek(8, 0, SEEK_SET)                   = 0
read(8, "rootfs / rootfs rw 0 0\n/dev/root "..., 1024) = 1024
stat("/", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat("/", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat("/dev", {st_mode=S_IFDIR|0755, st_size=4500, ...}) = 0
stat("/proc", {st_mode=S_IFDIR|0555, st_size=0, ...}) = 0
stat("/sys", {st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
stat("/selinux", {st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
stat("/proc/bus/usb", {st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
stat("/dev/pts", {st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
stat("/tmp", {st_mode=S_IFDIR|S_ISVTX|0777, st_size=4096, ...}) = 0
stat("/var/log/audit", {st_mode=S_IFDIR|0750, st_size=4096, ...}) = 0
stat("/mnt/target", {st_mode=S_IFDIR|0775, st_size=4096, ...}) = 0
stat("/boot", {st_mode=S_IFDIR|0755, st_size=3072, ...}) = 0
stat("/dev/shm", {st_mode=S_IFDIR|S_ISVTX|0777, st_size=120, ...}) = 0
stat("/proc/sys/fs/binfmt_misc", {st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
stat("/var/lib/nfs/rpc_pipefs", {st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
stat("/home/sgrubb/.gvfs",
Comment 5 Jeremy Katz 2009-07-09 09:04:55 EDT
That's the stat for available disk space from rpm.  Reassigning there.
Comment 6 Panu Matilainen 2009-07-09 10:01:12 EDT
Looks like a dupe or at least a variant of bug 505937.
Comment 7 Florian Festi 2010-02-03 11:00:29 EST
This problem has bee fixed upstream but the patch is too invasive to be ported
back to Fedora 11. Closing

Note You need to log in before you can comment on or make changes to this bug.