Bug 509558 - rhel5U4 server guest cannot suspend
rhel5U4 server guest cannot suspend
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Gleb Natapov
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-03 10:13 EDT by Cao, Chen
Modified: 2014-03-25 20:58 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-24 06:26:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg of 5u3 (15.69 KB, text/plain)
2009-07-06 03:27 EDT, Cao, Chen
no flags Details
dmesg of 5u4 - cannot suspend (33.76 KB, text/plain)
2009-07-06 03:28 EDT, Cao, Chen
no flags Details
dmesg of 5u4 non-xenkernel - cannot suspend (15.98 KB, application/octet-stream)
2009-07-06 03:42 EDT, Cao, Chen
no flags Details
dmesg - 5u3 x86 32bits non-xen non-pae (15.74 KB, application/octet-stream)
2009-07-06 04:41 EDT, Cao, Chen
no flags Details
dmesg - 5u3 x86_64 non-xen non-pae (14.91 KB, application/octet-stream)
2009-07-06 04:42 EDT, Cao, Chen
no flags Details
dmesg - 5u4 x86 32bits non-xen non-pae (16.73 KB, application/octet-stream)
2009-07-06 04:43 EDT, Cao, Chen
no flags Details
dmesg - 5u4 x86_64 non-xen non-pae (15.55 KB, text/plain)
2009-07-06 04:43 EDT, Cao, Chen
no flags Details

  None (edit)
Description Cao, Chen 2009-07-03 10:13:35 EDT
Description of problem:
the file /sys/power/status of rhel5u4 server is empty. and 
cannot suspend.
both 32bits and 64bits rhel5u4s.


Version-Release number of selected component (if applicable):
kvm-83-83.el5


How reproducible:
100% reproducible


Steps to Reproduce:
1. install rhel5u4 from tree RHEL5.4-Server-20090701.0 (with kernel 2.6.18-156)
2. in the guest issue command `cat /sys/power/status`
3. in the guest issue command `echo "disk" > /sys/power/status`
  
Actual results:
1.
after step2, the content of the file if empty.

2.
after step3, error msg pops up, invalid argument.


Expected results:
1.
after step2, the content should be "disk mem"

2.
after step3, the guest should suspend.


Additional info:
1.
command install geust:
/usr/libexec/qemu-kvm -drive file=5u4_x86_64.qcow2,media=disk,if=ide,cache=off,index=0,serial=fb-bde1-8bcf10f72b98 -net nic,macaddr=20:20:20:00:16:79,model=e1000 -net tap,script=/etc/qemu-ifup -rtc-td-hack -no-hpet -usbdevice tablet -cpu qemu64,+sse2 -smp 2 -m 2G -vnc :12 -drive file=/root/29/isos/boot.iso,media=cdrom,if=ide -boot c

2.
rhel5u4 server 32bits can suspend on physical machine, 
and the content of /sys/power/status is not empty.

3.
rhel5u4 server 64bits cannot suspend.
Comment 1 Eduardo Habkost 2009-07-03 15:59:48 EDT
Moving to NEW to mark it as free to be taken by the other developers.
Comment 2 lihuang 2009-07-04 04:03:01 EDT
FYI.
rhel5u4 server (20090701.0) i386/x86_84 on  physical box is support suspend .
[root@dhcp-66-70-3 ~]#cat /sys/power/state
standy mem disk

rhel5u4 guest, /sys/power/state is empty.


and in rhel5u3 i386/x86_64 guest. suspend is supported 
[root@dhcp-66-70-21 ~]#cat /sys/power/state
mem disk
Comment 3 Dor Laor 2009-07-05 10:01:12 EDT
On which kvm release it worked (if any) in the past
Comment 4 Cao, Chen 2009-07-05 22:39:38 EDT
We did not cover RHEL5U4 on the old versions of kvm.

but at least, this issue does exist on 
--
[root@o18 ~]# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor release 5.4-2.0.99 (8.2)
[root@o18 ~]# uname -a
Linux o18 2.6.18-155.el5 #1 SMP Fri Jun 19 17:06:31 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
--

still no content in the file of the guests.
Comment 5 Gleb Natapov 2009-07-06 03:05:34 EDT
please attach dmesg of rhel5.3 and rhel5.4 running in a guest
Comment 6 Cao, Chen 2009-07-06 03:27:16 EDT
Created attachment 350577 [details]
dmesg of 5u3

as the description
Comment 7 Cao, Chen 2009-07-06 03:28:22 EDT
Created attachment 350578 [details]
dmesg of 5u4 - cannot suspend

$description
Comment 8 Cao, Chen 2009-07-06 03:42:57 EDT
Created attachment 350580 [details]
dmesg of 5u4 non-xenkernel - cannot suspend

$description
Comment 9 Cao, Chen 2009-07-06 04:41:24 EDT
Created attachment 350585 [details]
dmesg - 5u3 x86 32bits non-xen non-pae

dmesg

CLI:
/usr/libexec/qemu-kvm -drive file=5.3s-32.img,media=disk,if=ide,cache=off,index=0,serial=fb-bde1-8bcf10f72b98 -net nic,macaddr=20:20:20:00:16:79,model=e1000 -net tap,script=/etc/qemu-ifup -rtc-td-hack -no-hpet -usbdevice tablet -cpu qemu64,+sse2 -smp 2 -m 1G -vnc :12
Comment 10 Cao, Chen 2009-07-06 04:42:21 EDT
Created attachment 350586 [details]
dmesg - 5u3 x86_64 non-xen non-pae

dmesg

CLI:
 /usr/libexec/qemu-kvm -drive file=5.3s-64.img,media=disk,if=ide,cache=off,index=0,serial=fb-bde1-8bcf10f72b98 -net nic,macaddr=20:20:20:00:16:79,model=e1000 -net tap,script=/etc/qemu-ifup -rtc-td-hack -no-hpet -usbdevice tablet -cpu qemu64,+sse2 -smp 2 -m 1G -vnc :12
Comment 11 Cao, Chen 2009-07-06 04:43:10 EDT
Created attachment 350587 [details]
dmesg - 5u4 x86 32bits non-xen non-pae

dmesg

CLI:
 /usr/libexec/qemu-kvm -drive file=5u4_x86_64.qcow2,media=disk,if=ide,cache=off,index=0,serial=fb-bde1-8bcf10f72b98 -net nic,macaddr=20:20:20:00:16:79,model=e1000 -net tap,script=/etc/qemu-ifup -rtc-td-hack -no-hpet -usbdevice tablet -cpu qemu64,+sse2 -smp 2 -m 1G -vnc :12
Comment 12 Cao, Chen 2009-07-06 04:43:59 EDT
Created attachment 350588 [details]
dmesg - 5u4 x86_64 non-xen non-pae

dmesg

CLI:
 /usr/libexec/qemu-kvm -drive file=5u4_x86_64.qcow2,media=disk,if=ide,cache=off,index=0,serial=fb-bde1-8bcf10f72b98 -net nic,macaddr=20:20:20:00:16:79,model=e1000 -net tap,script=/etc/qemu-ifup -rtc-td-hack -no-hpet -usbdevice tablet -cpu qemu64,+sse2 -smp 2 -m 1G -vnc :12
Comment 13 Cao, Chen 2009-07-06 04:44:48 EDT
(In reply to comment #11)
> Created an attachment (id=350587) [details]
> dmesg - 5u4 x86 32bits non-xen non-pae
> 
> dmesg
> 
> CLI:
>  /usr/libexec/qemu-kvm -drive
> file=5u4_x86_64.qcow2,media=disk,if=ide,cache=off,index=0,serial=fb-bde1-8bcf10f72b98
> -net nic,macaddr=20:20:20:00:16:79,model=e1000 -net tap,script=/etc/qemu-ifup
> -rtc-td-hack -no-hpet -usbdevice tablet -cpu qemu64,+sse2 -smp 2 -m 1G -vnc :12  

correct CLI:
/usr/libexec/qemu-kvm -drive file=5u4_x86.qcow2,media=disk,if=ide,cache=off,index=0,serial=fb-bde1-8bcf10f72b98 -net nic,macaddr=20:20:20:00:16:79,model=e1000 -net tap,script=/etc/qemu-ifup -rtc-td-hack -no-hpet -usbdevice tablet -cpu qemu64,+sse2 -smp 2 -m 1G -vnc :12
Comment 14 Cao, Chen 2009-07-06 06:11:34 EDT
just tested on xen-kernel and pae-kernel when filing this bug.

Because xen kernel does not support S3, 
and I cannot reproduce this on pae-kernel.

propose for closing this bug as "not a bug" or "cannot reproduce"( or "works for me"?).
Comment 16 Cao, Chen 2009-07-24 03:52:06 EDT
retested and passed.

please close this bug as NOTABUG.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.