Bug 509565 - Please revert the hunk that prevents gnome-default-applications-properties to set firefox options
Please revert the hunk that prevents gnome-default-applications-properties to...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-03 11:08 EDT by drago01
Modified: 2009-07-23 15:01 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.26.0-10.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-23 15:01:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description drago01 2009-07-03 11:08:13 EDT
Our control-center package ships with default-applications.patch with contains:

-----------
       <_name>Firefox</_name>
       <executable>firefox</executable>
       <command>firefox %s</command>
       <icon-name>firefox</icon-name>
       <run-in-terminal>false</run-in-terminal>
-      <netscape-remote>true</netscape-remote>
+      <netscape-remote>false</netscape-remote>
       <tab-command>firefox -new-tab "%s"</tab-command>
       <win-command>firefox -new-window "%s"</win-command>
     </web-browser>
     <web-browser>
-----------

This disables the radio buttons where the user can decide wheter to open a new window or new tab for external links.

I assume that this has been added because firefox provided the same options in its preferences dialog.

But now with firefox 3.5 this is no longer the case, so please revert this to allow users to set the preference for firefox.

I can just commit and build this for F11 and rawhide but I need an ACK first.
Comment 1 Matthias Clasen 2009-07-13 17:48:58 EDT
I can't say where this change came from; but your rationale for dropping it sounds fine. Please go ahead.
Comment 2 Fedora Update System 2009-07-14 11:30:30 EDT
control-center-2.26.0-10.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/control-center-2.26.0-10.fc11
Comment 3 Fedora Update System 2009-07-19 06:37:25 EDT
control-center-2.26.0-10.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update control-center'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7797
Comment 4 Fedora Update System 2009-07-23 15:01:34 EDT
control-center-2.26.0-10.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.