Bug 509576 - dracut drops to a shell after numerous mount errors
dracut drops to a shell after numerous mount errors
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-03 13:35 EDT by Clyde E. Kunkel
Modified: 2009-07-19 16:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-19 16:34:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
grub.conf, fstab, /proc/mdstat, dm tree (3.76 KB, text/plain)
2009-07-03 13:35 EDT, Clyde E. Kunkel
no flags Details

  None (edit)
Description Clyde E. Kunkel 2009-07-03 13:35:37 EDT
Created attachment 350450 [details]
grub.conf, fstab, /proc/mdstat, dm tree

Description of problem:
dracut drops to a shell after numerous Mount: you must specify the filesystem type.
then: Bug in initramfs /init deleted. Dropping to a shell. Good luck.
sh: cannot set terminal process group (-1): Inappropriate ioctl for device
sh: no job control in this shell

Version-Release number of selected component (if applicable):
[root@P5K-EWIFI ~]# rpm -q dracut
dracut-0.3-1.fc11.x86_64
[root@P5K-EWIFI ~]# dracut -v -f --omit debug /boot/dracut-2.6.29.5-191.fc11.x86_64 2.6.29.5-191.fc11.x86_64


How reproducible:
every time

Steps to Reproduce:
1. create dracut image, add to grub.conf
2. boot system
3.
  
Actual results:
error as above

Expected results:
normal boot

Additional info:

I don't have a serial setup, so hand transcribed screen msgs.

Also, I have a raid10, raid5 and raid container that dracut messes with
causing me to have to rebuild the arrays.  The arrays are not being used right now, but dracut insists on trying to start them improperly.
Comment 1 Clyde E. Kunkel 2009-07-03 15:36:49 EDT
Actually, this was in Fedora 11.  Rawhide is a bit too raw at present to test things.
Comment 2 Jóhann B. Guðmundsson 2009-07-17 13:48:13 EDT
A new release has just landed in koji with several improvements ( man dracut to see added kernel command line parameters ).. 

Download:
F-11: http://koji.fedoraproject.org/koji/buildinfo?buildID=114853
Rawhide: http://koji.fedoraproject.org/koji/buildinfo?buildID=114854 

Create your image with the debug module enable:

# dracut -a debug /boot/debug-$(uname -r) $(uname -r)

Add "rdshell" to the kernel command line, remove "rhgb" and "quiet" and boot the image.

Once you are dropped to a shell do:

# dmesg|grep dracut

Add the output and your kernel command line to the bug report.

There's also have been added a helper tool, which generates the kernel command line ( dracut-gencmdline ) 

Could you retest in with that version and report back thank you..
Comment 3 Clyde E. Kunkel 2009-07-18 23:17:01 EDT
used wget to get dracut from koji....

2009-07-18 23:13:16 (93.5 KB/s) - `dracut-0.5-1.fc11.x86_64.rpm' saved [71927/71927]

[kunkelc@P5K-EWIFI Fedora]$ sudo rpm -Uvh dracut-*
Preparing...                ########################################### [100%]
   1:dracut                 ########################################### [100%]
[kunkelc@P5K-EWIFI Fedora]$ su -
Password: 
[root@P5K-EWIFI ~]# dracut -a debug /boot/debug-$(uname -r) $(uname -r)
W: Possible missing firmware /lib/firmware/ql8100_fw.bin for module qla2xxx.ko
W: Possible missing firmware /lib/firmware/ql2500_fw.bin for module qla2xxx.ko
W: Possible missing firmware /lib/firmware/aic94xx-seq.fw for module aic94xx.ko
E: Failed to install strace
[root@P5K-EWIFI ~]#
Comment 4 Jóhann B. Guðmundsson 2009-07-19 14:44:09 EDT
Looks like strace is not installed on your system install strace and try again.. 
( #yum -y install strace && dracut -a debug /boot/debug-$(uname -r) $(uname -r) ) 

Probably the dracut should pull in strace when being installed since it's seems to error out if not present.
Comment 5 Clyde E. Kunkel 2009-07-19 16:34:48 EDT
right...it wasn't installed.  However, without -a debug, dracut now works!! Booted normally (at least it looks like it.)

$ dmesg | grep dracut
dracut: Starting plymouth daemon
dracut: Scanning for dmraid devices 
dracut: no raid disks
dracut: Scanning devices sda12 sdc2 sdc9 sdd2 sdd5 sde10 sdf15 sdf7  for LVM volume groups VolGroup02 
dracut: Reading all physical volumes. This may take a while...
dracut: Found volume group "VolGroup01" using metadata type lvm2
dracut: Found volume group "VolGroup03" using metadata type lvm2
dracut: Found volume group "VolGroup00" using metadata type lvm2
dracut: Found volume group "VolGroup02" using metadata type lvm2
dracut: 2 logical volume(s) in volume group "VolGroup02" now active
dracut: Assembling MD RAID arrays
dracut: Starting MD RAID array /dev/md0
dracut: mdadm: failed to run array /dev/md0: Device or resource busy
dracut: mdadm: no recognisable superblock on /dev/md0.
dracut: Starting MD RAID array /dev/md1
dracut: mdadm: failed to run array /dev/md1: Device or resource busy
dracut: mdadm: no recognisable superblock on /dev/md1.

mdacm --detail /devs md0, md1 and md127 show normal software raid devices and container.

I guess this bz can be closed.

Note You need to log in before you can comment on or make changes to this bug.