Bug 509589 - possible value for main org is incorrect.
possible value for main org is incorrect.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Shannon Hughes
Devan Goodwin
https://fjs-0-13.rhndev.redhat.com/rh...
:
: 499471 (view as bug list)
Depends On:
Blocks: 456998
  Show dependency treegraph
 
Reported: 2009-07-03 15:52 EDT by Preethi Thomas
Modified: 2009-09-10 15:49 EDT (History)
6 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:49:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
possible-value for entitlement (143.99 KB, image/png)
2009-07-07 08:07 EDT, Preethi Thomas
no flags Details
org-subscription (134.59 KB, image/png)
2009-07-09 08:48 EDT, Preethi Thomas
no flags Details
ise-default-org (4.49 KB, text/plain)
2009-07-09 08:53 EDT, Preethi Thomas
no flags Details

  None (edit)
Description Preethi Thomas 2009-07-03 15:52:06 EDT
Description of problem:

possible value for main org is  not correct.
Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090625.0-i386-embedded-oracle.iso

How reproducible:


Steps to Reproduce:
1. activate a satellite with cert with 100 management entitlement
2.go to Admin->Subscriptions->System Entitlements 
3.click on Entitlement name - say Management
4.go to the Organizations tab
5. see the possible values tab under proposed total
  
Actual results:

its shown as 0 to 200
attached screen shot
Expected results:
it should as  0 to 100

Additional info:
Comment 1 Clifford Perry 2009-07-06 09:44:34 EDT
Screen shot missing. ISO version missing as well. 

Can we reproduce this issue? Are you able to share login details so that devel can login and see the box in question?

Thanks,
Cliff
Comment 2 Preethi Thomas 2009-07-07 08:03:47 EDT
sorry,
I thought I added the screen shot.
ISO version
Satellite-5.3.0-RHEL5-re20090625.0-i386-embedded-oracle.iso
Comment 3 Preethi Thomas 2009-07-07 08:07:28 EDT
Created attachment 350783 [details]
possible-value for entitlement
Comment 5 Shannon Hughes 2009-07-07 16:04:27 EDT
fixes to 499471 busted this one. 

testplan:

1) default org should not be shown at all in the top list of orgs. changes from 499471 introduced the default org back into the list which is what caused problems
2) the info for default org should have been removed from the bottom info pane. there was a miscommunication in the earlier bug

so, 

the entitlement counts and usage should not include the entitlements consumed by org 1. tool tips were updated to help the user understand the counts in the bottom area of the page. 

this bug fixes both system entitlements and software entitlements under the subscription areas.
Comment 6 Shannon Hughes 2009-07-08 14:00:22 EDT
mass move to onqa
Comment 7 Preethi Thomas 2009-07-09 08:46:52 EDT
fails-qa
2 problems here
Problem 1

with just the default org
if you navigate to 
Admin->Subscriptions->System Entitlements->Management
and click on the organization tab.
ISE


Problem 2

create an org and 
now navigate to 
Admin->Subscriptions->System Entitlements->Management
the problem in https://bugzilla.redhat.com/show_bug.cgi?id=499471
is back
see the screen shot
Comment 8 Preethi Thomas 2009-07-09 08:48:08 EDT
Created attachment 351060 [details]
org-subscription
Comment 9 Preethi Thomas 2009-07-09 08:53:56 EDT
Created attachment 351065 [details]
ise-default-org
Comment 10 Shannon Hughes 2009-07-09 10:10:00 EDT
software side looks ok but i see the ise on system side. will take a look.
Comment 11 Shannon Hughes 2009-07-09 14:02:45 EDT
division by 0 error. fixed, 

81df874b0006e61af7ba7f614be468e004973fe9
Comment 12 Shannon Hughes 2009-07-10 08:54:01 EDT
mass move to onqa
Comment 13 Shannon Hughes 2009-07-13 12:14:14 EDT
there were two commits for this fix. looks ok on my local dev environment but busted when i do a git reset --hard. looks like one commit did not make both the vader and master branches. investigating.
Comment 14 Devan Goodwin 2009-07-17 09:39:56 EDT
Verified, default org no longer listed, no ISE when secondary orgs have 0 entitlements, and correct values shown after allocating entitlements to secondary orgs.
Comment 15 John Sefler 2009-07-30 18:27:05 EDT
*** Bug 499471 has been marked as a duplicate of this bug. ***
Comment 16 Brad Buckingham 2009-07-31 14:19:47 EDT
verified with 7/24 stage iso... moving to RELEASE_PENDING
Comment 17 Brandon Perkins 2009-09-10 15:49:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.