This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 509592 - Preupgrade lacks a means to clear out its cache, and yum won't remove it either (after failure or interruption)
Preupgrade lacks a means to clear out its cache, and yum won't remove it eith...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-03 16:49 EDT by Kev 'Kyrian' Green
Modified: 2014-01-21 18:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-05 12:28:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kev 'Kyrian' Green 2009-07-03 16:49:20 EDT
Description of problem:

Cause preupgrade to fail, either by not having enough space in /boot and having to install from a CD to get around it, or otherwise interrupting the install.

Thereafter there does not appear to be a means to clear the preupgrade cache equivalent to 'yum clean all', and 'yum clean all' won't do it either (presumably because there is no repo configuration for it).

Version-Release number of selected component (if applicable):

This happens when upgrading from FC10 to FC11 with preupgrade fails. The package ends up as version preupgrade-1.1.0-1.fc11.noarch.

How reproducible:

I don't want to try it again to prove it, but I imagine that it is easily reproducable by rebooting mid upgrade and the like.

Steps to Reproduce:
1. See "Description of problem:".
  
Actual results:

See "Description of problem:".

Expected results:

"preupgrade --clean" or "preupgrade clean all" existing and cleaning out the cache.

Additional info:

I reckon nobody thought of this yet is all.

If you get left with a mangled RPM database, "package-cleanup --dupes" coupled with clever shell scripting is VERY VERY much your friend in that situation. I do wish you'd finally get everything tagged as "fc$releasever.$arch" though, as it would make that shell scripting work in full rather than requiring manual intervention for the packages that aren't tagged in such a way.

Apologies for mis-tagging this bug, but FF3.5b4 from FC11 has taken a considerable dislike to your AJAX package/component selector, and would not allow me to select 'preupgrade' as the package.
Comment 1 Will Woods 2009-07-05 12:28:34 EDT
Actually there is a preupgrade --clean command already. The README says:

If you want to clean up manually, you can do:
  preupgrade --clean
Or, if you really want to be sure, do it by hand:
  grubby --remove-kernel=/boot/upgrade/vmlinuz
  rm -rf /var/cache/yum/preupgrade* /boot/upgrade

Note You need to log in before you can comment on or make changes to this bug.