Bug 509616 - With latest eclipse update
With latest eclipse update
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
: 510010 513587 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-04 01:48 EDT by Daniel Rowe
Modified: 2009-07-24 15:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-05 04:15:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Rowe 2009-07-04 01:48:20 EDT
Description of problem:

Yum updated eclipse and now eclipse is not loading plugins. For example I use the pydev plugin and this is not usable. I have also notice the SVN and PHP plugins are not working with the updated eclipse package.

Version-Release number of selected component (if applicable):

eclipse-pydev-1.4.4-2.fc11.x86_64

eclipse-platform 3.4.2-11.fc11

How reproducible:

Every time

Steps to Reproduce:

1. Start eclipse after update with plugin like pydev installed
2. Functionality not available 
  
Actual results:

Plugins not working.

Expected results:

All installed functionality and packages to work for example pydev.
Comment 1 Andrew Overholt 2009-07-04 04:46:40 EDT
Try running with -clean from the command line.  If that doesn't work, try moving ~/.eclipse out of the way.  This is an unfortunate upstream bug.

eclipse -clean -data /tmp/testWithClean

or

mv ~/.eclipse{,.bak20090704}; eclipse -data /tmp/testWithClean
Comment 2 Daniel Rowe 2009-07-04 10:19:53 EDT
Yes this works.... thanks.

I probably should have done this before I raised the bug.
Comment 3 Andrew Overholt 2009-07-05 04:15:22 EDT
(In reply to comment #2)
> Yes this works.... thanks.

Cool.

> I probably should have done this before I raised the bug.  

Don't worry, it *should* work and will in the 3.5 series.
Comment 4 Alexander Kurtakov 2009-07-20 03:39:38 EDT
*** Bug 510010 has been marked as a duplicate of this bug. ***
Comment 5 Andrew Overholt 2009-07-24 14:01:41 EDT
*** Bug 513587 has been marked as a duplicate of this bug. ***
Comment 6 Felix Schwarz 2009-07-24 14:50:12 EDT
Andrew: In bug 513587 you mentioned this is an upstream problem. Do you have a specific bug reference?
Comment 7 Andrew Overholt 2009-07-24 15:17:23 EDT
I can't recall the exact bug that Simon fixed this with, but these are likely relevant:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=251167
https://bugs.eclipse.org/bugs/show_bug.cgi?id=246765

Note You need to log in before you can comment on or make changes to this bug.