Bug 509648 - RFE Wine Version 1.1.28
RFE Wine Version 1.1.28
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
: 519621 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-04 10:18 EDT by Thomas Kowaliczek
Modified: 2009-09-11 19:30 EDT (History)
9 users (show)

See Also:
Fixed In Version: 1.1.29-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-11 19:30:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Kowaliczek 2009-07-04 10:18:15 EDT
Description of problem:
RFE WINE 1.1.25
Comment 1 Jeffrey Bonggren 2009-07-06 19:00:31 EDT
Seconded.  The memory management fixes are a big deal in 1.1.25.
Comment 2 Julian Sikorski 2009-07-09 12:29:26 EDT
Also, 1.1.24 suffers from this:
http://bugs.winehq.org/show_bug.cgi?id=19055
Comment 3 Thomas Kowaliczek 2009-08-09 05:04:49 EDT
Update to RFE 1.1.27 please
Comment 4 Thomas Kowaliczek 2009-08-23 19:32:56 EDT
Updatet to RFE 1.1.28
Comment 5 Andreas Bierfert 2009-08-26 17:44:03 EDT
Please play a little with these test builds as long as they are not pushed as updates:

rawhide: https://koji.fedoraproject.org/koji/taskinfo?taskID=1636622
F-11: https://koji.fedoraproject.org/koji/taskinfo?taskID=1636611
Comment 6 Andreas Bierfert 2009-08-27 00:49:41 EDT
*** Bug 519621 has been marked as a duplicate of this bug. ***
Comment 7 Thomas Kowaliczek 2009-08-30 17:10:04 EDT
Thank you for this package on my system f11 it works perfect :)
Comment 8 Julian Sikorski 2009-08-30 18:22:49 EDT
i586 wine still pulls only i586 nss-mdns. I'm not sure if this can be solved at all, though.
Comment 9 Thomas Kowaliczek 2009-08-30 19:34:21 EDT
i hate the pulseaudio patch. I must remove the packages from my system andd compile my own version of wine without pulseaudio patch.
Comment 10 Julian Sikorski 2009-08-30 19:49:06 EDT
Why don't you just uninstall wine-pulseaudio?
Comment 11 Thomas Kowaliczek 2009-08-31 06:35:57 EDT
I use Pluseaudio. But when i use it with wine over wincfg. Games can become many Sound Problems and one Game is crashing with the version here. And with an self compiled 1.1.28 it don´t crash.
Comment 12 Fedora Update System 2009-09-01 14:07:14 EDT
wine-1.1.28-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9220
Comment 13 The Source 2009-09-01 14:56:05 EDT
I just installed 1.1.28 (both i586 and x86_64). Wine Configuration crashes when I try to open Audio tab.
Comment 14 The Source 2009-09-01 15:01:08 EDT
winhlp32, winhlp64 and wordpad also crash with the following messages:

[thesource@MAXBOOK ~]$ wine wordpad
err:seh:call_stack_handlers no exception data found in system library for function 0
err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr (nil)

[thesource@MAXBOOK ~]$ wine winhlp32
err:seh:call_stack_handlers no exception data found in system library for function 0
err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr (nil)

[thesource@MAXBOOK ~]$ wine winhlp64
[thesource@MAXBOOK ~]$ err:seh:setup_exception nested exception on signal stack in thread 0018 eip 00000030e8410155 esp 00007f82f2b2b680 stack 0x7f82f1c82000-0x7f82f1d80000
err:seh:setup_exception nested exception on signal stack in thread 0013 eip 00000030e8410155 esp 00007f82f8beb680 stack 0x7f82f2332000-0x7f82f2430000
Comment 15 Andreas Bierfert 2009-09-01 15:04:53 EDT
These seem to be upstream 64bit related... try calling

wine32 wordpad
wine32 winhlp32
wine32 winecfg

as otherwise wine64 is called on x86_64 (see /usr/bin/wine).
Comment 16 The Source 2009-09-01 15:15:10 EDT
These ones work except winecfg (crashes on start). And it looks like I can't run any 64bit application (I tried WinRAR installer so far, I'll test more).
Comment 17 The Source 2009-09-01 15:17:07 EDT
wine32 winecfg works, probably was a temporary problem. Audio tab doesn't crash on 32bit version.
Comment 18 Andreas Bierfert 2009-09-01 15:40:40 EDT
See http://wiki.winehq.org/Wine64. I tried a round of pacman while testing...
Comment 19 Thomas Kowaliczek 2009-09-02 17:37:04 EDT
(In reply to comment #11)
> I use Pluseaudio. But when i use it with wine over wincfg. Games can become
> many Sound Problems and one Game is crashing with the version here. And with an
> self compiled 1.1.28 it don´t crash.  

Sorry for that it was my wrong. I see that it was/is an Bug the .28 version that broke the game.

Now please update your packages to .29 that i don't must compile it my self please :)
Comment 21 Thomas Kowaliczek 2009-09-03 06:57:11 EDT
I love you for that :)
Comment 22 Fedora Update System 2009-09-04 00:09:01 EDT
wine-1.1.29-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9304
Comment 23 Fedora Update System 2009-09-11 19:30:01 EDT
wine-1.1.29-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.