Bug 509677 - Saved passwords don't work with Firefox
Saved passwords don't work with Firefox
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-04 19:41 EDT by D. Wagner
Modified: 2009-10-08 10:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-24 16:29:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description D. Wagner 2009-07-04 19:41:06 EDT
Description of problem:

After upgrading from Fedora 10 -> Fedora 11, and consequently upgrading to the latest Firefox, Firefox seems to have forgotten all my remembered passwords, and is unable to remember any new passwords.

If I click on Edit :: Preferences :: Saved Passwords, I get an empty list (no sites are shown as having any saved passwords), even though I know I had dozens of sites with saved passwords before the upgrade.

If I go to a site where I previously had a saved password, Firefox does not auto-populate the username or password.

If I enter in my username and password manually, then Firefox pops up a prompt at the top of the page saying "Do you want Firefox to remember the password for ...?".  If I then click the "Remember" button, nothing happens: the prompt at the top of the page doesn't go away, nothing is added to the list of saved passwords, and returning to the site doesn't auto-log me in again.  Moreover if I pull up the Error Console, I noticed that when I clicked the "Remember" button, I got the following error:

Error: uncaught exception: [Exception... "'Couldn't write to database, login not added.' when calling method: [nsILoginManagerStorage::addLogin]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "JS frame :: file:///usr/lib64/xulrunner-1.9.1/components/nsLoginManager.js :: anonymous :: line 451" data: no]

I'm apparently not the only one to experience this; see here:
http://forums.fedoraforum.org/showthread.php?p=1237380

Version-Release number of selected component (if applicable):

firefox-3.5-1.fc11.x86_64

100% reproducible.
Comment 1 D. Wagner 2009-07-06 04:22:06 EDT
In case it is relevant: browsing the forums, I noticed two other users who also seem to be experiencing a similar problem (Firefox 3.5 not saving passwords):

http://forums.fedoraforum.org/showthread.php?t=225466
http://forums.fedoraforum.org/showthread.php?t=225468
Comment 2 Matěj Cepl 2009-07-24 07:55:23 EDT
Looks like some permission problem. Could I get output of these commands, please?

ls -lZ ~/.mozilla/firefox/*/*.sqlite*

and

getenforce

Thank you very much in advance.
Comment 3 D. Wagner 2009-07-24 13:05:38 EDT
I gave up and mv'd away the profile to save it, and started a fresh new profile.  But fortunately I saved the old profile (using mv), so I can still show the permissions, in case it is helpful.  Here they are:

$ ls -lZ *.sqlite                      
-rw-r--r--. daw daw unconfined_u:object_r:mozilla_home_t:s0 content-prefs.sqlite
-rw-r--r--. daw daw unconfined_u:object_r:mozilla_home_t:s0 cookies.sqlite
-rw-r--r--. daw daw unconfined_u:object_r:mozilla_home_t:s0 downloads.sqlite
-rw-r--r--. daw daw unconfined_u:object_r:mozilla_home_t:s0 dta_queue.sqlite
-rw-r--r--. daw daw unconfined_u:object_r:mozilla_home_t:s0 formhistory.sqlite
-rw-r--r--. daw daw unconfined_u:object_r:mozilla_home_t:s0 permissions.sqlite
-rw-r--r--. daw daw unconfined_u:object_r:mozilla_home_t:s0 places.sqlite
-rw-r--r--. daw daw unconfined_u:object_r:mozilla_home_t:s0 retailmenot.sqlite
-rw-r--r--. daw daw unconfined_u:object_r:mozilla_home_t:s0 search.sqlite
-rw-r--r--. daw daw unconfined_u:object_r:mozilla_home_t:s0 urlclassifier3.sqlite
-rw-r--r--. daw daw unconfined_u:object_r:mozilla_home_t:s0 webappsstore.sqlite
$ getenforce
Enforcing
$ id -a
uid=500(daw) gid=500(daw) groups=6(disk),500(daw) context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023

The permissions on the old *.sqlite files appear to be the same as the permissions on the *.sqlite files in my newly created profile.

There were no SELinux alerts apparent in setroubleshooter when using the old profile that caused the problems (I checked at the time).
Comment 4 Matěj Cepl 2009-07-24 16:29:54 EDT
(In reply to comment #3)
> The permissions on the old *.sqlite files appear to be the same as the
> permissions on the *.sqlite files in my newly created profile.
> 
> There were no SELinux alerts apparent in setroubleshooter when using the old
> profile that caused the problems (I checked at the time).  

OK, I give up ... there had to be something wrong with your profile (e.g., firefox is quite often not completely happy when being upgraded while running, or something). If you can reproduce it with a new one, please, reopen, and we will continue to work on it.

Closing as WORKSFORME.
Comment 5 Matt Castelein 2009-10-08 10:23:59 EDT
I have this same error with firefox-3.5.3-1.fc11.x86_64:

Error: uncaught exception: [Exception... "'Couldn't write to database, login not added.' when calling method: [nsILoginManagerStorage::addLogin]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: file:///usr/lib64/xulrunner-1.9.1/components/nsLoginManager.js :: anonymous :: line 451"  data: no]

Will try making a new profile to see if this goes away.
Comment 6 Matt Castelein 2009-10-08 10:31:43 EDT
Upon looking at my profile, I found that the following files and directories were owned by root:

Cache/
cookies.txt
mimeTypes.rdf
signons.sqlite

chown'ing these files to the correct user solved the problem.
I have no idea how they became owned by root in the first place.

Note You need to log in before you can comment on or make changes to this bug.