Bug 509680 - nautilus is erasing directly the files, it do not acept "asking before" configuration
nautilus is erasing directly the files, it do not acept "asking before" confi...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
10
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-04 20:36 EDT by private
Modified: 2015-03-03 17:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-24 08:35:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
software sistem version and gnome version....screenshot (139.25 KB, image/png)
2009-07-04 20:40 EDT, private
no flags Details

  None (edit)
Description private 2009-07-04 20:36:23 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.start nautilus

2.go to ------>  edit ---------> preferences ------> behavior  -------> trash bin ------> select ask before erase a file

3.select a file with mouse

4.press delete key
  
5. Actual results:

file erased
Expected results:
apearing of dialog window to confirm erasing

Additional info:

[root@alvaro-edicta-host ~]# lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8378 [KM400/A] Chipset Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237/VX700 PCI Bridge
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 80)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
01:00.0 VGA compatible controller: VIA Technologies, Inc. KM400/KN400/P4M800 [S3 UniChrome] (rev 01)
[root@alvaro-edicta-host ~]#
Comment 1 private 2009-07-04 20:40:16 EDT
Created attachment 350520 [details]
software sistem version and gnome version....screenshot
Comment 2 private 2009-07-04 21:01:40 EDT
the problem appeared after i uninstaled gnome-scan and instaled xsane.....

here is the list of installed software: http://fpaste.org/paste/17474
Comment 3 Tomáš Bžatek 2009-07-24 08:35:02 EDT
This is by design, moving files to trash (the Delete key) is done always without confirmation. This configuration option only affects deleting (either from the context menu or from the trash), not moving to trash.

Help for the /apps/nautilus/preferences/confirm_trash gconf key says 
"If set to true, then Nautilus will ask for confirmation when you attempt to delete files, or empty the Trash."

If you want to change this behaviour, feel free to open RFE ticket in bugzilla.gnome.org

Note You need to log in before you can comment on or make changes to this bug.