Bug 509682 - vmmouse_drv.so ABI version mismatch
vmmouse_drv.so ABI version mismatch
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vmmouse (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-04 22:22 EDT by Charlie Moschel
Modified: 2009-07-10 02:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-09 10:42:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Port vmmouse to xorg server input ABI 7 based on equivalent changes in generic mouse driver (2.90 KB, patch)
2009-07-09 04:28 EDT, Fabio Massimo Di Nitto
no flags Details | Diff

  None (edit)
Description Charlie Moschel 2009-07-04 22:22:04 EDT
Description of problem:
(EE) module ABI major version (4) doesn't match the server's version (7)

Version-Release number of selected component (if applicable):
x11-xorg-drv-vmmouse-12.6.4-1.fc12.i586

How reproducible:
Any current rawhide that tries to use vmmouse_drv.so

Steps to Reproduce:
1. install rawhide as a VM in vmware
2. boot
3.
  
Actual results:
No response to mouse movement

Expected results:
Mouse responds

Additional info:
(II) config/hal: Adding input device ImPS/2 Generic Wheel Mouse
(II) LoadModule: "vmmouse"
(II) Loading /usr/lib/xorg/modules/input/vmmouse_drv.so
(II) Module vmmouse: vendor="X.Org Foundation"
        compiled for 1.6.1, module version = 12.6.4
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 4.0
(EE) module ABI major version (4) doesn't match the server's version (7)
(II) UnloadModule: "vmmouse"
(II) Unloading /usr/lib/xorg/modules/input/vmmouse_drv.so
(EE) Failed to load module "vmmouse" (module requirement mismatch, 0)
(EE) No input driver matching `vmmouse'
(EE) config/hal: NewInputDeviceRequest failed (15)
Comment 1 BeGe 2009-07-07 02:35:28 EDT
Is there any foreseen correction or bypass on this bug (my rawhide doesn't startx anymore) ?
Comment 2 Charlie Moschel 2009-07-08 23:40:04 EDT
(In reply to comment #1)
> Is there any foreseen correction or bypass on this bug (my rawhide doesn't
> startx anymore) ?  

No, I haven't found one: I tried loading mouse_drv.so instead of vmmouse_drv.so, but to do that I had to set "AutoAddDevices" to "no".  That gets the mouse working, but then kbd_drv.so fails with a missing symbol and there is no keyboard input.
Comment 3 Fabio Massimo Di Nitto 2009-07-09 04:27:06 EDT
Hi all,

here is a temporary solution while waiting for an official fix from upstream and Peter Hutterer.

Rebuild this rpm and install (works for me at least):
http://fabbione.fedorapeople.org/xorg-x11-drv-vmmouse-12.6.4-2.fc12.src.rpm

Changes are:
- backport 370aab66b97a6fdc18f87d584a252f33f575899e git commit from upstream.
- cookup temporary patch to port vmmouse driver to Xorg server ABI 7 based
  on similar patches available in mouse driver.
- Fixes BZ #509682

I am attaching the patch in BZ too. Please understand that my Xorg skills are a bit rusty so it might not be the perfect patch for upstream but it works for me.
Comment 4 Fabio Massimo Di Nitto 2009-07-09 04:28:18 EDT
Created attachment 351025 [details]
Port vmmouse to xorg server input ABI 7 based on equivalent changes in generic mouse driver
Comment 5 Adam Jackson 2009-07-09 10:42:57 EDT
Should be fixed in vmmouse 12.6.4-2. Thanks for the patch!
Comment 6 Charlie Moschel 2009-07-09 19:12:12 EDT
(In reply to comment #5)
> Should be fixed in vmmouse 12.6.4-2. Thanks for the patch!  

OK, pulled from Koji, works for me.  Thanks!
Comment 7 BeGe 2009-07-10 02:53:07 EDT
I pulled it also from Koji and the mouse is back. Now i have some issues with french keyboard but i need to investigate a little bit more and at least the lastest updates of rawhide.
Many thanks.
Comment 8 Fabio Massimo Di Nitto 2009-07-10 02:59:35 EDT
(In reply to comment #7)
> I pulled it also from Koji and the mouse is back. Now i have some issues with
> french keyboard but i need to investigate a little bit more and at least the
> lastest updates of rawhide.
> Many thanks.  

while I was searching for this bug, I saw one about Level 3 "something" being broken in rawhide. Worth looking in bugzilla. IIRC fr keyboard setting requires Level 3 "something".

"something" being a word I can't remember this early in the morning ;)

Fabio

PS glad to see that the mouse is back to everybody.

Note You need to log in before you can comment on or make changes to this bug.