Bug 509697 - The david fonts in tex-fonts-hebrew contain no characters at all.
The david fonts in tex-fonts-hebrew contain no characters at all.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tex-fonts-hebrew (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Kenigsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-05 05:19 EDT by Matan Ziv-Av
Modified: 2009-07-23 15:02 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.1-12.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-23 15:02:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matan Ziv-Av 2009-07-05 05:19:26 EDT
Description of problem:

The font files 

david.vf
davidb.vf
davidi.vf
david.tfm
davidb.tfm
davidi.tfm
rdavid.tfm
rdavidb.tfm
rdavidi.tfm

Are empty fonts - they contain no characters at all.

This is probably related to 

https://bugzilla.redhat.com/show_bug.cgi?id=509695

Version-Release number of selected component (if applicable):
0.1-11.fc11
Comment 1 Dan Kenigsberg 2009-07-05 14:23:45 EDT
The problem is that culmus now carries DavidCLM as TrueType font instead of Type1. This is one reason that tex-fonts-hebrew is broken; I think there are others, since other fonts fail as well.
Comment 2 Matan Ziv-Av 2009-07-22 07:05:33 EDT
The culmus-david-clm-fonts package now includes Type1 fonts. Does tex-fonts-hebrew need to be rebuilt, or are more changes needed?
Comment 3 Fedora Update System 2009-07-22 15:23:06 EDT
tex-fonts-hebrew-0.1-12.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/tex-fonts-hebrew-0.1-12.fc11
Comment 4 Dan Kenigsberg 2009-07-22 15:34:00 EDT
(In reply to comment #2)
> The culmus-david-clm-fonts package now includes Type1 fonts. 

Thanks, Matan, for pushing for this in bug 509694.

> Does
> tex-fonts-hebrew need to be rebuilt, or are more changes needed?

Surprisingly, a rebuild was enough. Please test http://kojipkgs.fedoraproject.org/packages/tex-fonts-hebrew/0.1/12.fc11/noarch/tex-fonts-hebrew-0.1-12.fc11.noarch.rpm and report your success in https://admin.fedoraproject.org/updates/tex-fonts-hebrew-0.1-12.fc11 so it is more likely to be pushed to updates.
Comment 5 Fedora Update System 2009-07-23 15:02:49 EDT
tex-fonts-hebrew-0.1-12.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.