Bug 509706 - hplip driver prints garbage on HP DJ600
hplip driver prints garbage on HP DJ600
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-05 08:09 EDT by Milan Kerslager
Modified: 2009-07-13 07:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-13 07:41:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from troubleshoot wizard (933 bytes, text/plain)
2009-07-08 07:02 EDT, Milan Kerslager
no flags Details
SELinux alert from wizard run (2.44 KB, text/plain)
2009-07-08 07:37 EDT, Milan Kerslager
no flags Details
SELinux alert when wizard has been run (2.45 KB, text/plain)
2009-07-12 04:19 EDT, Milan Kerslager
no flags Details
Wizard troubleshoot log when parallel port choosed (843 bytes, text/plain)
2009-07-12 04:20 EDT, Milan Kerslager
no flags Details
Wizard troubleshoot log when hplip port choosed (933 bytes, text/plain)
2009-07-12 04:21 EDT, Milan Kerslager
no flags Details
SELinux alert with system-config-printer-1.1.8-3 (2.44 KB, text/plain)
2009-07-12 04:30 EDT, Milan Kerslager
no flags Details
Wizard troubleshoot log when hplip port choosed in new s-c-p (933 bytes, text/plain)
2009-07-12 04:31 EDT, Milan Kerslager
no flags Details
Wizard troubleshoot log when parallel port choosed in new s-c-p (843 bytes, text/plain)
2009-07-12 04:32 EDT, Milan Kerslager
no flags Details

  None (edit)
Description Milan Kerslager 2009-07-05 08:09:13 EDT
I have HP DeskJet 600 printer connected through paralel port to Fedora 11 box (x86_64). The printer has been added to the system through system-config-printer-gui with default driver (hplip) but then prints garbage ($$$ and other funny characters at top of the page) and hplip-gui reported communication error with the printer.

I switched to PCL-3 driver and then printer prints fine. The hplip-gui still report communication error with the device.
Comment 1 Tim Waugh 2009-07-06 07:10:30 EDT
Please update system-config-printer to the version from updates-testing:

yum --enablerepo=updates-testing update 'system-config-printer*'

After that, run the printing troubleshooter: System->Administration->Printing, then Help->Troubleshoot.  When it asks you to choose a printer, select 'Not listed', 'Locally connected printer', and then select the device concerned.  You should end up with a troubleshoot.txt file to save and attach to this bug report.

Thanks!
Comment 2 Milan Kerslager 2009-07-08 07:02:42 EDT
Created attachment 350913 [details]
Output from troubleshoot wizard

Output is from system-config-printer-1.1.8-3.fc11.x86_64 troubleshooting wizard.
Comment 3 Milan Kerslager 2009-07-08 07:37:08 EDT
Created attachment 350917 [details]
SELinux alert from wizard run

The wizard generated this SELinux alert. I'll try to use permissive mode.
Comment 4 Milan Kerslager 2009-07-08 08:09:23 EDT
I tryed to change driver to now recommended hpijs (3.9.2) and it works now.
Comment 5 Tim Waugh 2009-07-10 17:49:33 EDT
I'm confused.  Which driver was the one that had been configured automatically?

Perhaps you could run the troubleshooter again, but this time select the actual queue you are using.  Then attach the troubleshoot.txt file -- this will give me enough information to see which driver would have been selected automatically, as well as which driver is currently being used.
Comment 6 Milan Kerslager 2009-07-12 04:18:39 EDT
system-config-printer-1.1.7:
- see SELinux alert
- auto-configured hp:/par/DESKJET_600?device=/dev/parport0 with hpijs 3.9.2 just by few OK-clicks
- garbage printed, driver does not work
- wizard has been run (same SELinux alert) on existed printer, it asked to enable debugging output, but then waits too long
- wizard lists two same printers (parallel port and hplip connected)
Comment 7 Milan Kerslager 2009-07-12 04:19:22 EDT
Created attachment 351373 [details]
SELinux alert when wizard has been run
Comment 8 Milan Kerslager 2009-07-12 04:20:15 EDT
Created attachment 351374 [details]
Wizard troubleshoot log when parallel port choosed
Comment 9 Milan Kerslager 2009-07-12 04:21:14 EDT
Created attachment 351375 [details]
Wizard troubleshoot log when hplip port choosed
Comment 10 Milan Kerslager 2009-07-12 04:29:53 EDT
system-config-printer-1.1.8-3.fc11:
- hpijs 3.9.2 driver has been auto-choosed (just few OK-cliks)
- new SELinux alert
- testpage printed Ok
- wizard has been run (Not listed - Locally connected), two same printers listed (port only, parport0 HPLIP), both outputs attached
Comment 11 Milan Kerslager 2009-07-12 04:30:59 EDT
Created attachment 351376 [details]
SELinux alert with system-config-printer-1.1.8-3
Comment 12 Milan Kerslager 2009-07-12 04:31:46 EDT
Created attachment 351377 [details]
Wizard troubleshoot log when hplip port choosed in new s-c-p
Comment 13 Milan Kerslager 2009-07-12 04:32:26 EDT
Created attachment 351378 [details]
Wizard troubleshoot log when parallel port choosed in new s-c-p
Comment 14 Tim Waugh 2009-07-13 07:41:45 EDT
So the problem was fixed simply by upgrading system-config-printer?  Weird, but glad it works for you.

(For the SELinux alert, see bug #507098.)

Note You need to log in before you can comment on or make changes to this bug.