Bug 509708 - mc can't save configuration on clean system
mc can't save configuration on clean system
Status: CLOSED DUPLICATE of bug 507124
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-05 08:19 EDT by Marcin Slusarz
Modified: 2013-07-02 19:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-05 01:06:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcin Slusarz 2009-07-05 08:19:25 EDT
Description of problem:
mc doesn't create .mc directory, so:
- it can't save configuration
- mcedit can't save its buffer in ~/.mc/cedit/cooledit.clip (File->Copy to file)

Version-Release number of selected component (if applicable):
mc-4.6.2-10.fc11.x86_64

How reproducible:
every time

Additional info:

strace of debian-stable version (2:4.6.2~git20080311-4) contains this:
stat64("/home/marcin/.mc", 0xbff24f28)  = -1 ENOENT (No such file or directory)
mkdir("/home/marcin/.mc", 0777)         = 0
rename("/home/marcin/.mc.ini", "/home/marcin/.mc/ini") = -1 ENOENT (No such file or directory)
rename("/home/marcin/.mc.hot", "/home/marcin/.mc/hotlist") = -1 ENOENT (No such file or directory)
rename("/home/marcin/.mc.ext", "/home/marcin/.mc/bindings") = -1 ENOENT (No such file or directory)
rename("/home/marcin/.mc.menu", "/home/marcin/.mc/menu") = -1 ENOENT (No such file or directory)
rename("/home/marcin/.mc.bashrc", "/home/marcin/.mc/bashrc") = -1 ENOENT (No such file or directory)
rename("/home/marcin/.mc.inputrc", "/home/marcin/.mc/inputrc") = -1 ENOENT (No such file or directory)
rename("/home/marcin/.mc.tcshrc", "/home/marcin/.mc/tcshrc") = -1 ENOENT (No such file or directory)
rename("/home/marcin/.mc.tree", "/home/marcin/.mc/Tree") = -1 ENOENT (No such file or directory)
...
and then:
access("/home/marcin/.mc/ini", R_OK)    = -1 ENOENT (No such file or directory)
access("/usr/share/mc/mc.ini", R_OK)    = -1 ENOENT (No such file or directory)
open("/home/marcin/.mc/ini", O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)

fedora version contains only this:
access("/home/marcin/.mc/ini", R_OK)    = -1 ENOENT (No such file or directory)
access("/etc/mc/mc.ini", R_OK)          = -1 ENOENT (No such file or directory)
access("/usr/share/mc/mc.ini", R_OK)    = -1 ENOENT (No such file or directory)
access("/etc/mc/mc.lib", R_OK)          = 0
open("/home/marcin/.mc/ini", O_RDONLY)  = -1 ENOENT (No such file or directory)

Workaround:
mkdir ~/.mc
Comment 1 Maciej Żenczykowski 2009-08-04 17:20:05 EDT
Dup of 507124.
Comment 2 Jindrich Novy 2009-08-05 01:06:32 EDT

*** This bug has been marked as a duplicate of bug 507124 ***

Note You need to log in before you can comment on or make changes to this bug.