Bug 509746 - virt-manager: several accelerator and mnemonic key issues
virt-manager: several accelerator and mnemonic key issues
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
: 509989 511004 511008 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-05 13:53 EDT by Mark Xie
Modified: 2010-03-30 04:50 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:50:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add some UI mnemonics (1.65 KB, text/plain)
2009-12-15 14:29 EST, Cole Robinson
no flags Details

  None (edit)
Description Mark Xie 2009-07-05 13:53:30 EDT
Description of problem:
The user can not open the "Send Key" menu by keyboard

Version-Release number of selected component (if applicable):
virt-manager-0.6.1-5.el5

How reproducible:
allways

Steps to Reproduce:
1. Open virt-manager, then double click an exists guest to open the vm window, check the menu button at the top.
2. There is none keyboard method to open the "Send Key" menu
  
Actual results:
There is none keyboard method to open the "Send Key" menu

Expected results:
Every menu should have a short key, that will be better.

Additional info:
Comment 1 Cole Robinson 2009-10-13 12:22:29 EDT
*** Bug 511004 has been marked as a duplicate of this bug. ***
Comment 2 Cole Robinson 2009-10-13 12:27:03 EDT
I'm lumping together several issues into this one bug, since they are all similar:

- Alt-V in 'VM Details' is connected to two menus (so doesn't work correctly)
- In New VM wizard network pages, Alt-N and Alt-D should select proper fields.
- No shortcut for 'Finish' button in 'New Pool' wizard.
Comment 3 Cole Robinson 2009-10-13 12:28:13 EDT
*** Bug 511008 has been marked as a duplicate of this bug. ***
Comment 4 Cole Robinson 2009-10-13 12:28:28 EDT
*** Bug 509989 has been marked as a duplicate of this bug. ***
Comment 6 Cole Robinson 2009-12-15 14:29:05 EST
Created attachment 378597 [details]
Add some UI mnemonics

The third issue mentioned above actually isn't resolved in this patch: implementing it was proving to be a pain, and its a pretty trivial issue so I've decided not to fix it.
Comment 7 Cole Robinson 2009-12-15 14:42:53 EST
Fix built in virt-manager-0_6_1-9_el5
Comment 10 Johnny Liu 2010-01-11 00:15:08 EST
Verified PASS with virt-manager-0.6.1-12.el5 on RHEL5.4-Server-xen-x86_64.
Comment 12 errata-xmlrpc 2010-03-30 04:50:56 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0281.html

Note You need to log in before you can comment on or make changes to this bug.