Bug 509776 - nvidia driver specified; nouveau driver gets loaded as well
nvidia driver specified; nouveau driver gets loaded as well
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-06 03:16 EDT by Eli Wapniarski
Modified: 2009-07-21 15:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-21 15:57:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.88 KB, text/plain)
2009-07-06 03:16 EDT, Eli Wapniarski
no flags Details

  None (edit)
Description Eli Wapniarski 2009-07-06 03:16:20 EDT
Created attachment 350575 [details]
xorg.conf

Even though I have specified in my xorg.conf that xorg should load the "nvidia" driver, and the nvidia driver is indeed loaded, it would seem that somehow the nouveau driver also gets loaded.

Attached, you will find a copy of my xorg.conf file.
Comment 1 Eli Wapniarski 2009-07-06 04:51:04 EDT
Turns out that this is a kernel issue.

Sorry
Comment 2 Adam Williamson 2009-07-20 20:45:12 EDT
What exactly do you mean by the nouveau 'driver'? Can you post your Xorg.0.log?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Eli Wapniarski 2009-07-21 01:23:21 EDT
Please read comment #1. Its a kernel issue with nouveau framebuffer loading automatically. There was a guideline howto switch it off and it is no longer pestering me.

A bit of a pain actually. This is the first time that I'm aware of that a framebuffer was loaded without me specifying that it should be.
Comment 4 Adam Williamson 2009-07-21 13:42:44 EDT
Comment #1 doesn't say anything about framebuffer, hence my confusion. I wished to be clear whether you were talking about the nouveau X driver, or some other driver.

If you don't believe this is actually a bug, please close it. If you think it's a kernel bug, please re-assign it to the kernel.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Eli Wapniarski 2009-07-21 15:57:11 EDT
Sorry about the confusion. I don't think its a bug, but rather a sorta usability issue. Simply a conflict between proprietary drivers and the open source drivers.

I can't really complain so long as their is an option to enable everything to live peacefully together.

Thank you very much for your attention

Note You need to log in before you can comment on or make changes to this bug.