Bug 509788 - The virtual machine can't restart after reboot the guest(xen)
The virtual machine can't restart after reboot the guest(xen)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-06 04:26 EDT by Qunfang Zhang
Modified: 2009-12-14 16:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-06 07:44:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Failed to restart the vm (21.18 KB, image/png)
2009-07-06 04:26 EDT, Qunfang Zhang
no flags Details

  None (edit)
Description Qunfang Zhang 2009-07-06 04:26:15 EDT
Created attachment 350584 [details]
Failed to restart the vm

Description of problem:
I reboot a virtual machine (both para-virt and fully-virt) using two diffrent method: click the reboot button and input reboot in terminal of the guest. But the vm can't restart successfully. Now I list the actual results below:
(1)FV: both methods will make the vm shutdown instead of restart.
(2)PV: After reboot, the vm still run but can't restart, and there's a prompt says: Console not configured for guest(Please catch the attachment). So I click the "Hardware" tab, and find "Display" disappears. But if I force off this vm, and run it again, it will restart successfully. And the "Display" hardware will appear again.


Version-Release number of selected component (if applicable):
Host: RHEL5.4Client-x86_64
virt-manager -0.6.1-4.el5
xen-3.0.3-88.el5
libvirt-0.6.3-11.el5

How reproducible:
Always

Steps to Reproduce:
1.Create a vm (xen)
2.Reboot the guest,using reboot button or input "reboot" in the guest's terminal

  
Actual results:
The vms can't restart successfully

Expected results:
The vms can restart successful

Additional info:

#view /etc/xen/fv
#view /etc/xen/pv

name = "fv"
uuid = "c0f4cb74-c823-04e8-bec0-1ee1ae6c9187"
maxmem = 3096
memory = 512
vcpus = 4
builder = "hvm"
kernel = "/usr/lib/xen/boot/hvmloader"
boot = "c"
pae = 1
acpi = 1
apic = 1
localtime = 0
on_poweroff = "destroy"
on_reboot = "destroy"
on_crash = "destroy"
device_model = "/usr/lib64/xen/bin/qemu-dm"
sdl = 0
vnc = 1
vncunused = 1
keymap = "en-us"
disk = [ "file:/var/lib/xen/images/fv.img,hda,w", "file:/root/Desktop/rhel-server-5.3-x86_64-dvd.iso,hdc:cdrom,r" ]
vif = [ "mac=00:16:36:27:11:19,bridge=virbr0,script=vif-bridge,vifname=vif1.0" ]
parallel = "none"
serial = "pty"
soundhw = "es1370"
~                     


name = "pv"
uuid = "5887b39d-aaa4-f1ab-8ebd-df841c6a581a"
maxmem = 1024
memory = 1024
vcpus = 2
bootloader = "/usr/bin/pygrub"
on_poweroff = "destroy"
on_reboot = "restart"
on_crash = "restart"
vfb = [ "type=vnc,vncunused=1,keymap=en-us" ]
disk = [ "tap:aio:/var/lib/xen/images/pv-i386.img,xvda,w" ]
vif = [ "mac=00:16:36:42:d6:96,bridge=xenbr0,script=vif-bridge" ]
Comment 1 Qunfang Zhang 2009-07-06 04:38:40 EDT
Once when I reboot the guest of para-virt, the guest circulates from running to
shutdown, then from shutdown to running. And I can't delete or restart this
guest.
Comment 2 Qunfang Zhang 2009-07-06 07:32:36 EDT
Besides,
virt-viewer is in the same condition of virt-manager.
This issue just for xen not for kvm. Because guest for kvm is failed on reboot. It is unavailable.
Comment 3 Daniel Berrange 2009-07-06 07:42:18 EDT
You have reported 2 different problems in one bug, the inability to reboot the FV uest, and the failure of the PV guest after rebooting. Please open a separate issue for the PV guest problem.
Comment 4 Daniel Berrange 2009-07-06 07:44:02 EDT
You have explicitly configured your FV guest to shutdown when a reboot is requested, so this is not a virt-manager bug

on_reboot = "destroy"
Comment 5 Qunfang Zhang 2009-07-07 02:08:26 EDT
(In reply to comment #4)
> You have explicitly configured your FV guest to shutdown when a reboot is
> requested, so this is not a virt-manager bug
> 
> on_reboot = "destroy"  


Hi, When the vm(fv) is creating, I find on_reboot=restart.
But, when the vm finishs installation  and need reboot,I find on_reboot=destroy.
So,the vm can't reboot successfully.

Is this a libvirt bug?  If it is , can you reopen this issue to libvirt?
Thanks.

Version-Release number of selected component (if applicable):
Host: RHEL5.4Client-x86_64
virt-manager -0.6.1-4.el5
xen-3.0.3-88.el5
libvirt-0.6.3-13.el5

Note You need to log in before you can comment on or make changes to this bug.