Bug 509811 - Package sanity issues
Package sanity issues
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lapack (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-06 07:53 EDT by Susi Lehtola
Modified: 2009-08-14 17:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-14 16:40:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Susi Lehtola 2009-07-06 07:53:08 EDT
A couple of packaging issues:

- blas-devel and lapack-devel are not providing -static even if they include static libraries. (Are the static ones even necessary..?)

- Time stamps are not preserved for SOURCE4 and SOURCE5. (use cp -p instead of cp)

- Some non-utf8 in %changelog as revealed by rpmlint.

- Summary ended with dot.

- Names repeated in summaries, I suggest changing the summaries to the upstream versions
lapack: Linear Algebra Package
blas: Basic Linear Algebra Subprograms
Comment 1 Susi Lehtola 2009-07-27 18:24:21 EDT
While you're at it: LAPACK 3.2.1 has been available since April. It would be a good time to update to 3.2.1 before F12 branching occurs.
Comment 2 Tom "spot" Callaway 2009-07-27 18:35:03 EDT
I'm hoping that all of the MPI nonsense gets settled one way or the other in rawhide before attempting to clean up lapack, blas, and scalapack.
Comment 3 Susi Lehtola 2009-07-27 18:44:04 EDT
Oh, OK. But can't you update blas&lapack none the less as they aren't MPI specific?

Someone really should hang the persons who wrote ScaLAPACK, the API is that horrible.

(On the other hand, what can you do with a 8 character limit on variable names and no dynamic memory allocation! I'm just a bit surprised that I still haven't found an easy-to-use wrapper for it.)
Comment 4 Susi Lehtola 2009-07-31 03:48:06 EDT
(In reply to comment #2)
> I'm hoping that all of the MPI nonsense gets settled one way or the other in
> rawhide before attempting to clean up lapack, blas, and scalapack.  

You must have been thinking about BLACS and SCALAPACK, not BLAS and LAPACK which are not MPI packages at all.
Comment 5 Tom "spot" Callaway 2009-08-14 16:40:17 EDT
This is all fixed up in rawhide now:

http://koji.fedoraproject.org/koji/buildinfo?buildID=127327
Comment 6 Susi Lehtola 2009-08-14 17:20:57 EDT
Did you notice you removed the ΓΈ:s from the changelog? Before the update they were there.

Note You need to log in before you can comment on or make changes to this bug.