Bug 509832 - smb protocol not handled by any application when opening from a bookmark
smb protocol not handled by any application when opening from a bookmark
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-06 09:42 EDT by Steven Schveighoffer
Modified: 2015-03-03 17:40 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.2.3-9.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-04 20:41:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 573994 None None None Never
Launchpad 291259 None None None Never

  None (edit)
Description Steven Schveighoffer 2009-07-06 09:42:48 EDT
Description of problem:
When using nautilus, I can type in a samba url such as smb://servername/share and it opens correctly using samba.  However, if I use it to add a bookmark, then open the bookmark from the Places menu, it reports the following error:

Could not open location 'smb://servername/share'
No application is registered as handling this file.

Note, I am not sure the component that should be responsible, so i picked nautilus.  I'm sure it's not samba's fault, but I'm not sure which package should install the proper url handler in gconf.

Version-Release number of selected component (if applicable):
Nautilus version 2.26.3

How reproducible:
Always

Steps to Reproduce:
1. Navigate using nautilus to a server share
2. Save the location as a bookmark
3. Open the bookmark from the Places menu on the panel.
  
Actual results:
Error as described above

Expected results:
Open the server share

Additional info:
This is a related bug report from ubuntu, using the workaround outlined there, I have fixed the problem:
Comment 1 Tomáš Bžatek 2009-07-24 07:44:58 EDT
Can you post a link to the workaround you mentioned?

Works fine here with nautilus-2.27.4-1.fc12 and gvfs-1.3.2-1.fc12
Do you have gnome-vfs2 installed?
Comment 2 Steven Schveighoffer 2009-07-24 13:28:41 EDT
The link is in the external bugs section.  I guess I probably confused you with the description in Additional info.  I originally planned to put the link there, but then I found there was an external bugs section, so I used that, but did not update the description.
Comment 3 Steven Schveighoffer 2009-07-24 13:30:23 EDT
gnome vfs stuff:

[root@steveslaptop ~]# rpm -qa | grep vfs
gvfs-obexftp-1.2.3-7.fc11.i586
gnome-vfs2-2.24.1-2.fc11.i586
gvfs-archive-1.2.3-7.fc11.i586
gvfs-fuse-1.2.3-7.fc11.i586
gnome-vfs2-devel-2.24.1-2.fc11.i586
gvfs-smb-1.2.3-7.fc11.i586
gnome-vfs2-smb-2.24.1-2.fc11.i586
gnome-python2-gnomevfs-2.26.1-1.fc11.i586
gvfs-1.2.3-7.fc11.i586
gvfs-gphoto2-1.2.3-7.fc11.i586
Comment 4 Tomáš Bžatek 2009-08-04 11:55:35 EDT
I've built new packages gvfs-1.3.3-2.fc12 and gvfs-1.2.3-9.fc11, please test.
This fixes only smb-browse part of gvfs, i.e. URIs like smb://server/ or smb://workgroup/. In contrary, smb://server/share should be working with the current packages.
Comment 5 Fedora Update System 2009-08-04 12:02:12 EDT
gvfs-1.2.3-9.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gvfs-1.2.3-9.fc11
Comment 6 Steven Schveighoffer 2009-08-04 13:38:52 EDT
I can confirm that smb://servername/sharename indeed works with the current version, sorry for the error in my report.

Is there an easy way to install this update?  It looks like about 8 different packages, would like to use a yum command, but not sure how.  The advice on http://fedoraproject.org/wiki/QA/Updates_Testing did not work.
Comment 7 Fedora Update System 2009-08-04 20:41:47 EDT
gvfs-1.2.3-9.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Tomáš Bžatek 2009-08-05 04:37:54 EDT
(In reply to comment #6)
> Is there an easy way to install this update?  It looks like about 8 different
> packages, would like to use a yum command, but not sure how.  The advice on
> http://fedoraproject.org/wiki/QA/Updates_Testing did not work.  
You can either download them manually from http://koji.fedoraproject.org/koji/buildinfo?buildID=125618 or wait a few days before they get into the repositories.

Let me know then if it fixed this issue.
Comment 9 Steven Schveighoffer 2009-08-05 13:09:55 EDT
Just downloaded the updates, it did indeed fix the issue, thanks!

Note You need to log in before you can comment on or make changes to this bug.