Bug 509843 - Writing to a tape is possible, reading is not - aic79xx driver issue [NEEDINFO]
Writing to a tape is possible, reading is not - aic79xx driver issue
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
i686 Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-06 10:14 EDT by Tomasz Cholewa
Modified: 2014-06-02 09:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:23:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (tomekc)


Attachments (Terms of Use)

  None (edit)
Description Tomasz Cholewa 2009-07-06 10:14:25 EDT
Description of problem:

It is impossible to read data written to a SCSI tape although it is possible to write it without any problem.




How reproducible:
Always


Steps to Reproduce:
1. Write a file to a tape:

 tar cpf /dev/nst0 /var/log/messages

2. Rewind tape

 mt -f /dev/nst0 rewind

3. Read a content of a tape

 tar tvf /dev/nst0
  
Actual results:
Whenever I try to read a data from a tape I get a bunch of SCSI error messages and tar shows:

tar: /dev/nst0: Cannot read: Input/output error


Hardware is fine because it actually works under Ubuntu 9.04 Live cd - I have no problem in reading data there.


Expected results:
Reading data from a tape is possible.


Additional info:

SCSI card is Adaptec 29320LPE.

Log messages when trying to read data:

Jul  6 14:45:56 localhost kernel: scsi1: Transmission error detected
Jul  6 14:45:56 localhost kernel: LQISTAT1[0x0] LASTPHASE[0x40] SCSISIGI[0xa0] PERRDIAG[0x30]
Jul  6 14:45:56 localhost kernel: >>>>>>>>>>>>>>>>>> Dump Card State Begins <<<<<<<<<<<<<<<<<
Jul  6 14:45:56 localhost kernel: scsi1: Dumping Card State at program address 0x20b Mode 0x11
Jul  6 14:45:56 localhost kernel: Card was paused
Jul  6 14:45:56 localhost kernel: INTSTAT[0x8] SELOID[0x4] SELID[0x0] HS_MAILBOX[0x0]
Jul  6 14:45:56 localhost kernel: INTCTL[0x80] SEQINTSTAT[0x0] SAVED_MODE[0x11] DFFSTAT[0x19]
Jul  6 14:45:56 localhost kernel: SCSISIGI[0xb6] SCSIPHASE[0x4] SCSIBUS[0x0] LASTPHASE[0x40]
Jul  6 14:45:56 localhost kernel: SCSISEQ0[0x0] SCSISEQ1[0x12] SEQCTL0[0x0] SEQINTCTL[0x0]
Jul  6 14:45:56 localhost kernel: SEQ_FLAGS[0x20] SEQ_FLAGS2[0x0] QFREEZE_COUNT[0x0]
Jul  6 14:45:56 localhost kernel: KERNEL_QFREEZE_COUNT[0x0] MK_MESSAGE_SCB[0xff00]
Jul  6 14:45:56 localhost kernel: MK_MESSAGE_SCSIID[0xff] SSTAT0[0x2] SSTAT1[0x11]
Jul  6 14:45:56 localhost kernel: SSTAT2[0x0] SSTAT3[0x0] PERRDIAG[0x0] SIMODE1[0xac]
Jul  6 14:45:56 localhost kernel: LQISTAT0[0x0] LQISTAT1[0x0] LQISTAT2[0x0] LQOSTAT0[0x0]
Jul  6 14:45:56 localhost kernel: LQOSTAT1[0x0] LQOSTAT2[0x0]
Jul  6 14:45:56 localhost kernel:
Jul  6 14:45:56 localhost kernel: SCB Count = 4 CMDS_PENDING = 1 LASTSCB 0xffff CURRSCB 0x3 NEXTSCB 0x0
Jul  6 14:45:56 localhost kernel: qinstart = 11 qinfifonext = 11
Jul  6 14:45:56 localhost kernel: QINFIFO:
Jul  6 14:45:56 localhost kernel: WAITING_TID_QUEUES:
Jul  6 14:45:56 localhost kernel: Pending list:
Jul  6 14:45:56 localhost kernel:   3 FIFO_USE[0x0] SCB_CONTROL[0x40] SCB_SCSIID[0x47]
Jul  6 14:45:56 localhost kernel: Total 1
Jul  6 14:45:56 localhost kernel: Kernel Free SCB list: 2 1 0
Jul  6 14:45:56 localhost kernel: Sequencer Complete DMA-inprog list:
Jul  6 14:45:56 localhost kernel: Sequencer Complete list:
Jul  6 14:45:56 localhost kernel: Sequencer DMA-Up and Complete list:
Jul  6 14:45:56 localhost kernel: Sequencer On QFreeze and Complete list:
Jul  6 14:45:56 localhost kernel:
Jul  6 14:45:56 localhost kernel:
Jul  6 14:45:56 localhost kernel: scsi1: FIFO0 Free, LONGJMP == 0x80ff, SCB 0x0
Jul  6 14:45:56 localhost kernel: SEQIMODE[0x3f] SEQINTSRC[0x0] DFCNTRL[0x0] DFSTATUS[0x89]
Jul  6 14:45:56 localhost kernel: SG_CACHE_SHADOW[0x2] SG_STATE[0x0] DFFSXFRCTL[0x0]
Jul  6 14:45:56 localhost kernel: SOFFCNT[0x0] MDFFSTAT[0x5] SHADDR = 0x00, SHCNT = 0x0
Jul  6 14:45:56 localhost kernel: HADDR = 0x00, HCNT = 0x0 CCSGCTL[0x10]
Jul  6 14:45:56 localhost kernel: scsi1: FIFO1 Active, LONGJMP == 0x8063, SCB 0x3
Jul  6 14:45:56 localhost kernel: SEQIMODE[0x3f] SEQINTSRC[0x0] DFCNTRL[0x8] DFSTATUS[0x89]

Jul  6 14:45:56 localhost kernel: SOFFCNT[0x0] MDFFSTAT[0x14] SHADDR = 0x23e1200c0, SHCNT = 0x0
Jul  6 14:45:56 localhost kernel: HADDR = 0x23e1200c0, HCNT = 0x0 CCSGCTL[0x10]
Jul  6 14:45:56 localhost kernel: LQIN: 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0
Jul  6 14:45:56 localhost kernel: scsi1: LQISTATE = 0x0, LQOSTATE = 0x0, OPTIONMODE = 0x52
Jul  6 14:45:57 localhost kernel: scsi1: OS_SPACE_CNT = 0x20 MAXCMDCNT = 0x0
Jul  6 14:45:57 localhost kernel: scsi1: SAVED_SCSIID = 0x0 SAVED_LUN = 0x0
Jul  6 14:45:57 localhost kernel: SIMODE0[0xc]
Jul  6 14:45:57 localhost kernel: CCSCBCTL[0x4]
Jul  6 14:45:57 localhost kernel: scsi1: REG0 == 0x3, SINDEX = 0x180, DINDEX = 0x10a
Jul  6 14:45:57 localhost kernel: scsi1: SCBPTR == 0x3, SCB_NEXT == 0xffc0, SCB_NEXT2 == 0xfff6
Jul  6 14:45:57 localhost kernel: CDB 12 0 0 82 8 4c
Jul  6 14:45:57 localhost kernel: STACK: 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0
Jul  6 14:45:57 localhost kernel: <<<<<<<<<<<<<<<<< Dump Card State Ends >>>>>>>>>>>>>>>>>>
Jul  6 14:45:57 localhost kernel: scsi1: device overrun (status a) on 0:4:0
Jul  6 14:45:57 localhost kernel:  target1:0:4: Wide Transfers Fail
Jul  6 14:45:57 localhost kernel:  target1:0:4: FAST-80 WIDE SCSI 160.0 MB/s DT (12.5 ns, offset 64)
Jul  6 14:45:57 localhost kernel: scsi1: Transmission error detected
Jul  6 14:45:57 localhost kernel: LQISTAT1[0x0] LASTPHASE[0x60] SCSISIGI[0x60] PERRDIAG[0x4]
Jul  6 14:45:57 localhost kernel: >>>>>>>>>>>>>>>>>> Dump Card State Begins <<<<<<<<<<<<<<<<<
Jul  6 14:45:57 localhost kernel: scsi1: Dumping Card State at program address 0x1e9 Mode 0x11
Jul  6 14:45:57 localhost kernel: Card was paused
Jul  6 14:45:57 localhost kernel: INTSTAT[0x8] SELOID[0x4] SELID[0x0] HS_MAILBOX[0x0]
Jul  6 14:45:57 localhost kernel: INTCTL[0x80] SEQINTSTAT[0x0] SAVED_MODE[0x11] DFFSTAT[0x19]
Jul  6 14:45:57 localhost kernel: SCSISIGI[0x75] SCSIPHASE[0x2] SCSIBUS[0xa] LASTPHASE[0x60]
Jul  6 14:45:57 localhost kernel: SCSISEQ0[0x0] SCSISEQ1[0x12] SEQCTL0[0x0] SEQINTCTL[0x0]
Jul  6 14:45:57 localhost kernel: SEQ_FLAGS[0x0] SEQ_FLAGS2[0x0] QFREEZE_COUNT[0x1]
Jul  6 14:45:57 localhost kernel: KERNEL_QFREEZE_COUNT[0x1] MK_MESSAGE_SCB[0xff00]
Jul  6 14:45:57 localhost kernel: MK_MESSAGE_SCSIID[0xff] SSTAT0[0x0] SSTAT1[0x19]
Jul  6 14:45:57 localhost kernel: SSTAT2[0x0] SSTAT3[0x0] PERRDIAG[0x0] SIMODE1[0xac]
Jul  6 14:45:57 localhost kernel: LQISTAT0[0x0] LQISTAT1[0x0] LQISTAT2[0x0] LQOSTAT0[0x0]
Jul  6 14:45:57 localhost kernel: LQOSTAT1[0x0] LQOSTAT2[0x0]
Jul  6 14:45:57 localhost kernel:
Jul  6 14:45:57 localhost kernel: SCB Count = 4 CMDS_PENDING = 1 LASTSCB 0xffff CURRSCB 0x3 NEXTSCB 0x0
Jul  6 14:45:57 localhost kernel: qinstart = 13 qinfifonext = 13
Jul  6 14:45:57 localhost kernel: QINFIFO:
Jul  6 14:45:57 localhost kernel: WAITING_TID_QUEUES:
Jul  6 14:45:57 localhost kernel: Pending list:
Jul  6 14:45:57 localhost kernel:   3 FIFO_USE[0x0] SCB_CONTROL[0x40] SCB_SCSIID[0x47]
Jul  6 14:45:57 localhost kernel: Kernel Free SCB list: 2 1 0
Jul  6 14:45:57 localhost kernel: Sequencer Complete DMA-inprog list:
Jul  6 14:45:57 localhost kernel: Sequencer Complete list:
Jul  6 14:45:57 localhost kernel: Sequencer DMA-Up and Complete list:
Jul  6 14:45:57 localhost kernel: Sequencer On QFreeze and Complete list:

Jul  6 14:45:57 localhost kernel:
Jul  6 14:45:57 localhost kernel: scsi1: FIFO0 Free, LONGJMP == 0x80ff, SCB 0x0
Jul  6 14:45:57 localhost kernel: SEQIMODE[0x3f] SEQINTSRC[0x0] DFCNTRL[0x0] DFSTATUS[0x89]
Jul  6 14:45:57 localhost kernel: SG_CACHE_SHADOW[0x2] SG_STATE[0x0] DFFSXFRCTL[0x0]
Jul  6 14:45:57 localhost kernel: SOFFCNT[0x1] MDFFSTAT[0x5] SHADDR = 0x00, SHCNT = 0x0
Jul  6 14:45:57 localhost kernel: HADDR = 0x00, HCNT = 0x0 CCSGCTL[0x10]
Jul  6 14:45:57 localhost kernel:
Jul  6 14:45:57 localhost kernel: scsi1: FIFO1 Active, LONGJMP == 0x8063, SCB 0x3
Jul  6 14:45:57 localhost kernel: SEQIMODE[0x3f] SEQINTSRC[0x0] DFCNTRL[0x4] DFSTATUS[0x88]
Jul  6 14:45:57 localhost kernel: SG_CACHE_SHADOW[0x3] SG_STATE[0x0] DFFSXFRCTL[0x0]
Jul  6 14:45:57 localhost kernel: SOFFCNT[0x1] MDFFSTAT[0x54] SHADDR = 0x064, SHCNT = 0xffffa2
Jul  6 14:45:57 localhost kernel: HADDR = 0x00, HCNT = 0x0 CCSGCTL[0x10]
Jul  6 14:45:57 localhost kernel: LQIN: 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0 0x0
Jul  6 14:45:57 localhost kernel: scsi1: LQISTATE = 0x0, LQOSTATE = 0x0, OPTIONMODE = 0x52
Jul  6 14:45:57 localhost kernel: scsi1: OS_SPACE_CNT = 0x20 MAXCMDCNT = 0x0
Jul  6 14:45:57 localhost kernel: scsi1: SAVED_SCSIID = 0x0 SAVED_LUN = 0x0
Jul  6 14:45:57 localhost kernel: SIMODE0[0xc]
Jul  6 14:45:57 localhost kernel: CCSCBCTL[0x4]
Jul  6 14:45:57 localhost kernel: scsi1: REG0 == 0x3, SINDEX = 0x180, DINDEX = 0x10a
Jul  6 14:45:57 localhost kernel: scsi1: SCBPTR == 0x3, SCB_NEXT == 0xffc0, SCB_NEXT2 == 0xfff6
Jul  6 14:45:57 localhost kernel: CDB 12 0 0 0 60 0
Jul  6 14:45:57 localhost kernel: STACK: 0x206 0x0 0x0 0x0 0x0 0x0 0x0 0x0
Jul  6 14:45:57 localhost kernel: <<<<<<<<<<<<<<<<< Dump Card State Ends >>>>>>>>>>>>>>>>>>
Jul  6 14:45:57 localhost kernel: scsi1: device overrun (status a) on 0:4:0
Jul  6 14:45:57 localhost kernel:  target1:0:4: Domain Validation detected failure, dropping back
Jul  6 14:45:57 localhost kernel:  target1:0:4: FAST-40 WIDE SCSI 80.0 MB/s DT (25 ns, offset 64)
Jul  6 14:45:57 localhost kernel: scsi1: Transmission error detected
Jul  6 14:45:57 localhost kernel: LQISTAT1[0x0] LASTPHASE[0x60] SCSISIGI[0xa0] PERRDIAG[0x24]
Jul  6 14:45:57 localhost kernel: >>>>>>>>>>>>>>>>>> Dump Card State Begins <<<<<<<<<<<<<<<<<
Jul  6 14:45:57 localhost kernel: scsi1: Dumping Card State at program address 0x20a Mode 0x11
Jul  6 14:45:57 localhost kernel: Card was paused
Comment 1 Pedro 2012-07-17 10:01:36 EDT
I have a very similar error on x86_64 architecture. Can archive data to tape, but can't restore it. dmesg output is very similar to what is shown here. Any updates on this bug?
Comment 2 Tomasz Cholewa 2012-07-17 10:11:02 EDT
(In reply to comment #1)
> I have a very similar error on x86_64 architecture. Can archive data to
> tape, but can't restore it. dmesg output is very similar to what is shown
> here. Any updates on this bug?

I can tell you that we didn't manage to run this on red hat kernel. We resolved this issue by compiling the kernel by ourselves (2.6.30). Of course it's not a final solution to this problem and I'm sure it's not recommended or supported by Red Hat, but it works.
Comment 3 RHEL Product and Program Management 2014-03-07 08:55:44 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 4 RHEL Product and Program Management 2014-06-02 09:23:13 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.