Bug 509848 - Improve store sizing documentation (small messages and geometry variability)
Improve store sizing documentation (small messages and geometry variability)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Messaging_Programming_Reference (Show other bugs)
Development
All Linux
medium Severity medium
: 1.3
: ---
Assigned To: Alison Young
MRG Quality Engineering
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-06 10:29 EDT by Kim van der Riet
Modified: 2012-09-21 08:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-16 01:17:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kim van der Riet 2009-07-06 10:29:59 EDT
Small messages (of several bytes) have large storage overheads in the journal. In addition, the exact capacity at which the enqueue capacity exception is thrown is not a constant, but can vary depending on journal geometry. (Bug 509573, comment 1 gives a summary of the issues)

The current documentation does not adequately describe how to estimate storage requirements for small messages and how to take into account the threshold variability of the store. An improved size estimation section needs to be written which better helps users estimate the journal size and variability.
Comment 2 Kim van der Riet 2009-12-18 13:15:36 EST
Some additional detail on determining the expected size of a journal and some sizing strategies were added to the 1.2 MRG Messaging User Guide section on Persistence.

This documentation is improved, but not comprehensive. The complexity of the issue and the large number of issues that can affect the sizing of a queue make it difficult to provide a guide that is both comprehensive and easy to understand.
Comment 3 Alison Young 2011-03-16 01:17:06 EDT
Closed due to bug being against unsupported book version and to clear off docs bug radar. 
If still applicable against current version (2.0), feel free reopen bug.

Note You need to log in before you can comment on or make changes to this bug.