Bug 509863 - 'Attempt to call an unsupported action kickstart.initate' on RHEL 2.1 with spacewalk-koan
'Attempt to call an unsupported action kickstart.initate' on RHEL 2.1 with sp...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
low Severity low
: ---
: ---
Assigned To: Justin Sherrill
Steve Salevan
:
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-07-06 11:10 EDT by Steve Salevan
Modified: 2009-08-25 16:25 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-10 10:14:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Salevan 2009-07-06 11:10:54 EDT
Description of problem:
If a user attempts to initiate a kickstart on RHEL 2.1 with the spacewalk-koan package, rhn_check will error out with the following error:

do_call(kickstart.initiate, ('<client fqdn>', 'spacewalk-koan', ' ksdevice=eth0 ', '', '<satellite fqdn>:1', []))
Sending back response: (6, 'Invalid function call attempted', {}) 

Version-Release number of selected component (if applicable):
530, 6/25 build

How reproducible:
Always

Steps to Reproduce:
1. Register a RHEL 2.1 box to a 530 Satellite
2. Attempt to kickstart it
  
Actual results:
Errors as above

Expected results:
Kickstart initiated by spacewalk-koan

Additional info:
Comment 1 Steve Salevan 2009-07-06 11:24:49 EDT
Clarification: client and satellite fqdns were cut out of the original error message...  the text was not taken verbatim from the output of rhn_check.
Comment 3 Justin Sherrill 2009-07-08 15:33:44 EDT
Can't seem to reproduce this locally, waiting on a reproducer.
Comment 5 Steve Salevan 2009-07-10 10:14:52 EDT
Try as I may, I cannot reproduce this bug on any 2.1 machine.  It seems like the original issue was based on an eccentricity of my original 2.1 machine's setup, and after updating its packages, provisioning succeeded.  Moving to CLOSED, NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.