Bug 509956 - Eclipse remains in memory after exiting
Eclipse remains in memory after exiting
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
: 581276 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 02:44 EDT by Steve
Modified: 2010-08-23 15:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-23 15:15:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Config information of Fedora Eclipse (341.10 KB, application/octet-stream)
2009-07-08 19:39 EDT, Steve
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 546542 None None None Never
Eclipse Project 247705 None None None Never

  None (edit)
Description Steve 2009-07-07 02:44:58 EDT
Description of problem:

Fedora Eclipse remains in memory even after exiting

Version-Release number of selected component (if applicable):

eclipse-platform-3.4.2-11.fc11.i586
eclipse-cdt-5.0.2-2.fc11.i586

How reproducible:

Always

Steps to Reproduce:
1.  Start up Fedora Eclipse
2.  Exit from Fedora Eclipse 
3.  Type 'ps aux | grep eclipse' at command line
  
Actual results:

eclipse is still running

Expected results:

eclipse should not be running after it has been exited

Additional info:
Comment 1 Andrew Overholt 2009-07-07 11:09:42 EDT
I can't reproduce this.  What JVM are you using?
Comment 2 Steve 2009-07-07 19:24:33 EDT
This is what java -version gives:

java version "1.6.0_0"
OpenJDK Runtime Environment (IcedTea6 1.5) (fedora-22.b16.fc11-i386)
OpenJDK Server VM (build 14.0-b15, mixed mode)

Configuration details (just the java section):

*** Date: Wednesday, July 8, 2009 9:21:48 AM Australia (Brisbane)

*** Platform Details:

*** System properties:
eclipse.buildId=M20090211-1700
eclipse.commands=-os
linux
-ws
gtk
-arch
x86
-showsplash
/usr/lib/eclipse//plugins/org.fedoraproject.ide.platform_3.4.2/splash.bmp
-launcher
/usr/lib/eclipse/eclipse
-name
Eclipse
--launcher.library
/usr/lib/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.0.101.R34x_v20080805/eclipse_1116.so
-startup
/usr/lib/eclipse/plugins/org.eclipse.equinox.launcher_1.0.101.R34x_v20081125.jar
-vm
/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/../lib/i386/client/libjvm.so
eclipse.ee.install.verify=false
eclipse.home.location=file:/usr/lib/eclipse/
eclipse.launcher=/usr/lib/eclipse/eclipse
eclipse.p2.data.area=@config.dir/../p2
eclipse.p2.profile=PlatformProfile
eclipse.product=org.fedoraproject.ide.platform.product
eclipse.startTime=1247008887140
eclipse.vm=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/../lib/i386/client/libjvm.so
eclipse.vmargs=-Xms40m
-Xmx512m
-XX:MaxPermSize=128m
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-Djava.class.path=/usr/lib/eclipse/plugins/org.eclipse.equinox.launcher_1.0.101.R34x_v20081125.jar
file.encoding=UTF-8
file.encoding.pkg=sun.io
file.separator=/
java.awt.graphicsenv=sun.awt.X11GraphicsEnvironment
java.awt.printerjob=sun.print.PSPrinterJob
java.class.path=/usr/lib/eclipse/plugins/org.eclipse.equinox.launcher_1.0.101.R34x_v20081125.jar
java.class.version=50.0
java.endorsed.dirs=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/endorsed
java.ext.dirs=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/ext:/usr/java/packages/lib/ext
java.home=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre
java.io.tmpdir=/tmp
java.library.path=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/i386/client:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/i386:/opt/intel/ccompiler/lib:/usr/lib/xulrunner-1.9.1:/usr/lib/xulrunner-1.9.1:/usr/java/packages/lib/i386:/lib:/usr/lib
java.runtime.name=OpenJDK Runtime Environment
java.runtime.version=1.6.0_0-b16
java.specification.name=Java Platform API Specification
java.specification.vendor=Sun Microsystems Inc.
java.specification.version=1.6
java.vendor=Sun Microsystems Inc.
java.vendor.url=http://java.sun.com/
java.vendor.url.bug=http://java.sun.com/cgi-bin/bugreport.cgi
java.version=1.6.0_0
java.vm.info=mixed mode
java.vm.name=OpenJDK Client VM
java.vm.specification.name=Java Virtual Machine Specification
java.vm.specification.vendor=Sun Microsystems Inc.
java.vm.specification.version=1.0
java.vm.vendor=Sun Microsystems Inc.
java.vm.version=14.0-b15
line.separator=
Comment 3 Andrew Overholt 2009-07-08 11:01:44 EDT
Alex, can you duplicate on x86?  The launching mechanism on x86_64 spawns a separate JVM process whereas it uses libjvm to do it in-process on x86.
Comment 4 Alexander Kurtakov 2009-07-08 11:29:51 EDT
No, it exits cleanly for me. 
Is this happening everytime?
What eclipse plugins you have installed (just in case)?
Can you attach your latest ~/.eclipse/org.eclipse.platform*/configuration/*.log file?
Comment 5 Steve 2009-07-08 19:39:46 EDT
Created attachment 351004 [details]
Config information of Fedora Eclipse
Comment 6 Steve 2009-07-08 19:40:25 EDT
Yes, it happens everytime.  When it is still in memory and I open Eclipse again, it starts up a new process of it.  So after a few exists and restarts, I'll have many eclipse processes stuck in memory.

I couldn't find the log file you mentioned so I copied and pasted the configuration information I get from the About section.
Comment 7 Steve 2009-08-05 08:26:49 EDT
The problem has gone away after the recent series of update.  I guess it has been solved. :)
Comment 8 Andrew Overholt 2009-11-05 14:00:00 EST
Steve, when you were experiencing this, did you have GNOME accessibility enabled?  If so, I think it might be this bug:

https://bugzilla.gnome.org/show_bug.cgi?id=546542
Comment 9 Andrew Overholt 2010-01-05 09:08:40 EST
I've added some external bug references.  This does indeed appear to be an upstream issue when GNOME a11y is enabled.
Comment 10 Felix Schwarz 2010-04-12 14:37:03 EDT
*** Bug 581276 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.