This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 51005 - Installer could offer to use X config used by installer if X config fails.
Installer could offer to use X config used by installer if X config fails.
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
roswell
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-06 10:18 EDT by Need Real Name
Modified: 2007-03-26 23:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-09 18:33:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-06 10:18:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.6-ph-01 i686)

Description of problem:
During graphical install, X works...  But chip isn't directly supported...
X setup fails... It would be cool if the installer offered to drop in the X
config used by the installer.

How reproducible:
Always

Steps to Reproduce:
1. Graphical install on bleeding edge notebook, or what-have-you (goes OK)
2. X setup fails.
3. :(
	

Actual Results:  Ended up raking around in the install images, looking for
the X config file, to try it.

Expected Results:  "Your X configuration appears to have failed.  Would you
like to use the 'safe' config file being used by this graphical install?" 
[yes/no]

Additional info:

Also would be nice to be able to get to the video card selection screen
from the monitor selection screen.
Comment 1 Mike A. Harris 2001-08-09 14:55:10 EDT
The GUI install use XFree86-FBDev-3.3.6 to run the installation process
itself.  You can try installing that and configuring a framebuffer if
you like.  What video hardware are you using?

lspci -v
Comment 2 Need Real Name 2001-08-09 18:33:51 EDT
Yes, configuring the frame buffer device is what needs to happen in this case. 
Alas, I was unable to get that working in the time I had, not being familiar
with FBDev.  After the fact I realized that since X was running for the install,
it might be simple enough to "clone" that setup. It might have resulted in a
successful install, instead of a failed one...

The video is a "Trident CyberBlade XP" on a HP Pavilion N5470 notebook.  I don't
have the machine here to run 'lspci -v'.

This XFree86 failure is not a redhat bug, I don't think -- it's the way it is
with bleeding edge video and X.  I'm just suggesting an enhancement to help work
around similar situations, where the "right" driver, (i.e. Trident) fails, but
the FBDev works.  Even a file dropped in /etc/X11 with the install config and a
hint as to any kernel vga arguments which might be good in these all too common
cases.
Comment 3 David Lawrence 2001-08-23 14:41:07 EDT
 At some point in the future, the Xconfigurator tool may allow
framebuffer configuration. CUrrently, it allows it via --usefbdev
at the CLI. It isn't detailed config though and does not set up
the kernel framebuffer. It is a start though.

Note You need to log in before you can comment on or make changes to this bug.