Bug 510050 - xcb-util (or is it really VLC in rpmfusion?) dependency issues
xcb-util (or is it really VLC in rpmfusion?) dependency issues
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xcb-util (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Michal Nowak
Fedora Extras Quality Assurance
https://bugzilla.rpmfusion.org/show_b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 11:00 EDT by Anthony de Almeida Lopes
Modified: 2013-03-07 21:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-08 04:18:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony de Almeida Lopes 2009-07-07 11:00:12 EDT
I've just done an upgrade from Fedora 10 to 11 and now I get the following
error after installing xcb-util (implicitly, as a dependency of VLC)

libxcb-keysyms.so.0()(64bit) is needed by package
vlc-core-1.0.0-0.11rc3.fc11.x86_64 : Success - empty transaction

Currently have 0.3.3-2.fc11 installed.

I'm not sure if this is a Fedora problem or an RPM Fusion problem with VLC.
Please advise.

....

I just removed (xcb-util-0.3.3-2.fc11.x86_64) xcb-util and re-installed
(xcb-util-0.3.4-1.fc11.x86_64) via YUM.
Now, when installing vlc, I get the following:

root@lifebook64:~ (0) % yum install vlc
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package vlc.x86_64 0:1.0.0-0.11rc3.fc11 set to be updated
--> Processing Dependency: vlc-core = 1.0.0-0.11rc3.fc11 for package:
vlc-1.0.0-0.11rc3.fc11.x86_64
--> Processing Dependency: libvlccore.so.2()(64bit) for package:
vlc-1.0.0-0.11rc3.fc11.x86_64
--> Running transaction check
---> Package vlc-core.x86_64 0:1.0.0-0.11rc3.fc11 set to be updated
--> Processing Dependency: libxcb-keysyms.so.0()(64bit) for package:
vlc-core-1.0.0-0.11rc3.fc11.x86_64
--> Finished Dependency Resolution
vlc-core-1.0.0-0.11rc3.fc11.x86_64 from rpmfusion-free has depsolving problems
  --> Missing Dependency: libxcb-keysyms.so.0()(64bit) is needed by package
vlc-core-1.0.0-0.11rc3.fc11.x86_64 (rpmfusion-free)
Error: Missing Dependency: libxcb-keysyms.so.0()(64bit) is needed by package
vlc-core-1.0.0-0.11rc3.fc11.x86_64 (rpmfusion-free)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
Comment 1 Michal Nowak 2009-07-08 04:18:50 EDT
Notabug. This has nothing to do with xcb-util. This is problem with your system configuration.

  * libxcb-keysyms.so.0 is in xcb-util <= 0.3.3
  * libxcb-keysyms.so.1 is in xcb-util >= 0.3.4

While having installed xcb-util-0.3.4 you have to have vlc-core-1.0.0-0.12rc4+ in your rpmfusion repos. Enable -updates and/or -update-testing and try it once again. If not helped clean yum cache: `sudo yum clean all` and try it once more again. xcb-util-0.3.4-1 is certainly in f11 stable: https://admin.fedoraproject.org/updates/F11/FEDORA-2009-6326 as well as current vlc-core: https://bugzilla.rpmfusion.org/show_bug.cgi?id=714#c4
Comment 2 Anthony de Almeida Lopes 2009-07-08 04:30:50 EDT
Thanks. Sorry about the bug. "yum clean all" fixed it all.

Note You need to log in before you can comment on or make changes to this bug.