Bug 510052 - error on SATA Intel Corporation ICH9M/M-E SATA AHCI Controller
error on SATA Intel Corporation ICH9M/M-E SATA AHCI Controller
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 11:07 EDT by Lukas Tvrdy
Modified: 2009-07-21 14:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-21 14:17:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
smartctl -a /dev/sda (9.10 KB, text/plain)
2009-07-08 12:39 EDT, Lukas Tvrdy
no flags Details

  None (edit)
Description Lukas Tvrdy 2009-07-07 11:07:01 EDT
Description of problem:
System freezees for few minutes, sometimes the partition is remounted as read-only (can't reproduce it by some steps) and system became unusable


Version-Release number of selected component (if applicable):
Linux 2.6.29.5-191.fc11.i586 #1 SMP Tue Jun 16 23:11:39 EDT 2009 i686 i686 i386 GNU/Linux

Device:
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)

Laptop:
HP dv5-1035ec

How reproducible:
Randomly occurs during longer work on laptop, when I recompile bigger projects like KOffice, KDevelop and sometimes I just surf net in Firefox.
 
Additional info:
/var/log/messages (shows in dmesg too)
...
Jul  7 16:47:37 pavilion kernel: ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
Jul  7 16:47:37 pavilion kernel: ata1.00: irq_stat 0x40000001
Jul  7 16:47:37 pavilion kernel: ata1.00: cmd 35/00:00:b3:3a:51/00:04:0f:00:00/e0 tag 0 dma 524288 out
Jul  7 16:47:37 pavilion kernel:         res 51/10:d0:d5:3c:51/00:01:0f:00:00/e0 Emask 0x81 (invalid argument)
Jul  7 16:47:37 pavilion kernel: ata1.00: status: { DRDY ERR }
Jul  7 16:47:37 pavilion kernel: ata1.00: error: { IDNF }
Jul  7 16:47:37 pavilion kernel: ata1.00: configured for UDMA/100
Jul  7 16:47:37 pavilion kernel: sd 0:0:0:0: [sda] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul  7 16:47:37 pavilion kernel: sd 0:0:0:0: [sda] Sense Key : Aborted Command [current] [descriptor]
Jul  7 16:47:37 pavilion kernel: Descriptor sense data with sense descriptors (in hex):
Jul  7 16:47:37 pavilion kernel:        72 0b 14 00 00 00 00 0c 00 0a 80 00 00 00 00 00
Jul  7 16:47:37 pavilion kernel:        0f 51 3c d5
Jul  7 16:47:37 pavilion kernel: sd 0:0:0:0: [sda] Add. Sense: Recorded entity not found
Jul  7 16:47:37 pavilion kernel: end_request: I/O error, dev sda, sector 256981683
Jul  7 16:47:37 pavilion kernel: Buffer I/O error on device dm-0, logical block 12611712
Jul  7 16:47:37 pavilion kernel: lost page write due to I/O error on dm-0
Jul  7 16:47:37 pavilion kernel: Buffer I/O error on device dm-0, logical block 12611713
Jul  7 16:47:37 pavilion kernel: lost page write due to I/O error on dm-0
Jul  7 16:47:37 pavilion kernel: Buffer I/O error on device dm-0, logical block 12611714
Jul  7 16:47:37 pavilion kernel: lost page write due to I/O error on dm-0
Jul  7 16:47:37 pavilion kernel: Buffer I/O error on device dm-0, logical block 12611715
Jul  7 16:47:37 pavilion kernel: lost page write due to I/O error on dm-0
Jul  7 16:47:37 pavilion kernel: Buffer I/O error on device dm-0, logical block 12611716
Jul  7 16:47:37 pavilion kernel: lost page write due to I/O error on dm-0
Jul  7 16:47:37 pavilion kernel: Buffer I/O error on device dm-0, logical block 12611717
Jul  7 16:47:37 pavilion kernel: lost page write due to I/O error on dm-0
Jul  7 16:47:37 pavilion kernel: Buffer I/O error on device dm-0, logical block 12611718
Jul  7 16:47:37 pavilion kernel: lost page write due to I/O error on dm-0
Jul  7 16:47:37 pavilion kernel: Buffer I/O error on device dm-0, logical block 12611719
Jul  7 16:47:37 pavilion kernel: lost page write due to I/O error on dm-0
Jul  7 16:47:37 pavilion kernel: Buffer I/O error on device dm-0, logical block 12611720
Jul  7 16:47:37 pavilion kernel: lost page write due to I/O error on dm-0
Jul  7 16:47:37 pavilion kernel: Buffer I/O error on device dm-0, logical block 12611721
Jul  7 16:47:37 pavilion kernel: lost page write due to I/O error on dm-0
Jul  7 16:47:37 pavilion kernel: ata1: EH complete
Jul  7 16:47:37 pavilion kernel: sd 0:0:0:0: [sda] 312581808 512-byte hardware sectors: (160 GB/149 GiB)
Jul  7 16:47:37 pavilion kernel: sd 0:0:0:0: [sda] Write Protect is off
Jul  7 16:47:37 pavilion kernel: sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
...
Comment 1 Chuck Ebbert 2009-07-07 20:32:33 EDT
IDNF is a severe disk hardware error. Check the SMART logs on the disk...
Comment 2 Lukas Tvrdy 2009-07-08 12:39:40 EDT
Created attachment 350966 [details]
smartctl -a /dev/sda

I checked the /var/log/messages and nothing serious shows up. Just one warning that smart was not able to read attribute abd that is all.

I attached smartctl -a /dev/sda output.

Do you think that he hardware is bad? Can I fix this error by a software tool or I need to replace harddrive?
Comment 3 Matěj Cepl 2009-07-19 12:19:27 EDT
Isn't this duplicate of bug 485551?
Comment 4 Lukas Tvrdy 2009-07-20 15:54:11 EDT
Matej Cepl:
I don't think so. That bug has something with CD-Rom. I'm just using my disk.

It seems that my hardware is buggy, I already sent it to service and will wait for their answer.
Comment 5 Chuck Ebbert 2009-07-21 14:17:07 EDT
(In reply to comment #2)

> 
> Do you think that he hardware is bad? Can I fix this error by a software tool
> or I need to replace harddrive?  

There are 50 errors in the log.

Note You need to log in before you can comment on or make changes to this bug.