Bug 510058 - The Virtualization Guide does not document how to install, configure, or use KVM
The Virtualization Guide does not document how to install, configure, or use KVM
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Virtualization_Guide (Show other bugs)
5.4
All Linux
high Severity high
: rc
: 5.4
Assigned To: Christopher Curran
Joshua Wulf
: Documentation
Depends On:
Blocks: 499522
  Show dependency treegraph
 
Reported: 2009-07-07 11:18 EDT by Jon Thomas
Modified: 2014-10-19 18:57 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-08 15:16:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Thomas 2009-07-07 11:18:19 EDT
The Virtualization Guide does not document how to install, configure, or use KVM.  The only mention of KVM is in the glossary.

This is the doc:

http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/Virtualization_Guide/index.html
Comment 4 Issue Tracker 2009-07-13 16:12:22 EDT
Event posted on 07-13-2009 04:12pm EDT by jkachuck

------- Comment From mknutson@us.ibm.com 2009-07-13 15:56 EDT-------
Red Hat - When will we see KVM documentation?  what it supports, what it
doesn't support, how to use it, what are it's limits in numbers of
guests, amount of RAM needed, disk space, how to install it, how to peg
guests to specific HW components, what are optimal configurations, ....
are just a small sample of what we expect to see and need for final
acceptance testing.  We need this in order to test the product properly
for our customer consumption and guidance.  I am elevating the severity of
this bug - during Alpha this may have been a "normal" problem, during
beta - it is now a severe "ship" problem for our OS acceptance teams and
for our customers.  During RC cuts this is quickly  becomming a "block" 
issue.  Please send out the information ASAP.


This event sent from IssueTracker by jkachuck 
 issue 313758
Comment 7 Christopher Curran 2009-07-20 00:39:37 EDT
This functionality is planned and on schedule. There is a partner documentation review scheduled for the 30th of July. 

RHEL engineering and documentation schedules do not often align due to technical and resource issues. Basically, we cannot document products until the product can be tested. Presently, the Virtualization Guide is in development and Quality Engineering. KVM will be 70% documented by the 30th of July for partner beta and fully documented for the documentation Release Candidate on the 14th of August.

Further planning details can be found here:
https://engineering.redhat.com/trac/ContentServices/wiki/VirtfivefourInfoPlan

Chris Curran
Comment 8 Issue Tracker 2009-07-21 14:57:46 EDT
Event posted on 07-20-2009 12:39am EDT by bugzilla

These changes made by ccurran@redhat.com.
Bugzilla comment added:
 This functionality is planned and on schedule. There is a partner
documentation review scheduled for the 30th of July. 

RHEL engineering and documentation schedules do not often align due to
technical and resource issues. Basically, we cannot document products
until the product can be tested. Presently, the Virtualization Guide is in
development and Quality Engineering. KVM will be 70% documented by the 30th
of July for partner beta and fully documented for the documentation Release
Candidate on the 14th of August.

Further planning details can be found here:
https://engineering.redhat.com/trac/ContentServices/wiki/VirtfivefourInfoPlan

Chris Curran


https://bugzilla.redhat.com/show_bug.cgi?id=510058

This event sent from IssueTracker by jkachuck 
 issue 313758
Comment 9 Issue Tracker 2009-07-21 14:57:48 EDT
Event posted on 07-21-2009 07:12am EDT by Glen Johnson

------- Comment From iranna.ankad@in.ibm.com 2009-07-21 07:08 EDT-------
(In reply to comment #9)

Hello RedHat,
We have another IBM bug open (mentioned below) that needs to be considered
documentation.
i.e Bug 54339   -  lsi_scsi: error,during kvm guest installation using
scsi disk in RHEL5.4 Alpha

We got to know during recent RH virtualization call (dated 24/06) that
"Emulated scsi are not supported as virt device".

Please make sure this is documented in the Virtualization Guide.

Thanks!


This event sent from IssueTracker by jkachuck 
 issue 313758
Comment 10 Issue Tracker 2009-07-21 14:57:50 EDT
Event posted on 07-21-2009 11:50am EDT by Glen Johnson

------- Comment From mknutson@us.ibm.com 2009-07-21 11:39 EDT-------
upping priority and severity since there has been no activity to correct
it. - this will cause major customer satisfaction issues and has affected
our ability to properly test.  We cannot complete testing prior to release
without this being corrected ASAP.


This event sent from IssueTracker by jkachuck 
 issue 313758
Comment 12 Issue Tracker 2009-07-31 11:24:35 EDT
Event posted on 07-17-2009 04:51am EDT by Glen Johnson

------- Comment From kamaleshb@in.ibm.com 2009-07-17 04:50 EDT-------
Hello redhat,

Any updates on the bug ?

Thanks,
kamalesh.


This event sent from IssueTracker by dfisher 
 issue 313758
Comment 13 Issue Tracker 2009-08-03 11:18:34 EDT
Event posted on 08-03-2009 08:43am EDT by Glen Johnson

------- Comment From iranna.ankad@in.ibm.com 2009-08-03 08:40 EDT-------
(In reply to comment #10)
> (In reply to comment #9)
>
> Hello RedHat,
> We have another IBM bug open (mentioned below) that needs to be
considered
> documentation.
> i.e Bug 54339   -  lsi_scsi: error,during kvm guest installation using
scsi
> disk in RHEL5.4 Alpha
>
> We got to know during recent RH virtualization call (dated 24/06) that
> "Emulated scsi are not supported as virt device".
>
> Please make sure this is documented in the Virtualization Guide.
>
>
> Thanks!
>

Hello Redhat,
I do not find any mention of SCSI emulation saying it is NOT supported, in
the
KVM documentation attached (i.e virt-draft.pdf)

Please let us know what's your thought.

Thanks!


This event sent from IssueTracker by jkachuck 
 issue 313758
Comment 15 Issue Tracker 2009-08-12 11:18:44 EDT
Event posted on 08-11-2009 10:33pm EDT by Glen Johnson

------- Comment From iranna.ankad@in.ibm.com 2009-08-11 14:44 EDT-------
(In reply to comment #19)

Hello Redhat,
We do not find any mention of SCSI emulation saying it is NOT supported,
in the 2nd draft of
KVM documentation as well (i.e virt-draft2.pdf)

All, I see (in page 317) is
"Software virtualization is unsupported by Red Hat Enterprise Linux"
It was little unclear to me what it means.

Please point us correct documentation for  SCSI emulation unsupport.

Thanks!


This event sent from IssueTracker by jkachuck 
 issue 313758
Comment 16 Issue Tracker 2009-08-17 13:47:12 EDT
Event posted on 08-14-2009 12:44pm EDT by Glen Johnson

------- Comment From iranna.ankad@in.ibm.com 2009-08-14 12:26 EDT-------
Hello RedHat FYI,
We have opened below new documentation bugzilla, which is a specific
documentation request for SCSI emulation unsupport.

i.e Bug 55410   -  RIT329710- Document unsupport of SCSI emulation in
RHEL5.4 KVM

Thanks!


This event sent from IssueTracker by jkachuck 
 issue 313758
Comment 17 Issue Tracker 2009-08-17 13:47:15 EDT
Event posted on 08-17-2009 01:25pm EDT by Glen Johnson

------- Comment From tpnoonan@us.ibm.com 2009-08-17 13:17 EDT-------
Hi Lawrence Lim, fyi, here are the RHEL5.4 Virtualization Guide Bugzillas
that IBM opened:

55410  -  RIT329710- Document unsupport of SCSI emulation in RHEL5.4 KVM

55445  -  RIT330586- Please update virtualization documentation for KVM to
use virsh

55378  -  RIT328762: Slow guest installs with KVM
(this one is actually a new real defect and a separate bugzilla will be
opened on the documentation part referenced in the defect bugzilla).

Thanks.


This event sent from IssueTracker by jkachuck 
 issue 313758

Note You need to log in before you can comment on or make changes to this bug.