This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 510081 - rootpw not working in Kickstart
rootpw not working in Kickstart
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:3cf5fef866ef102b9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 12:04 EDT by Kai Meyer
Modified: 2009-07-07 12:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-07 12:40:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (132.58 KB, text/plain)
2009-07-07 12:05 EDT, Kai Meyer
no flags Details

  None (edit)
Description Kai Meyer 2009-07-07 12:04:59 EDT
This bug was filed automatically by anaconda.
Comment 1 Kai Meyer 2009-07-07 12:05:04 EDT
Created attachment 350828 [details]
Attached traceback automatically from anaconda.
Comment 2 Kai Meyer 2009-07-07 12:08:34 EDT
I have tried this with two different kickstarts. This particular backtrace resulted from the kickstart pasted at the end of this comment. I have tried with the exact same ks, but changing the rootpw line to "rootpw --iscrypted $1$MJGn1di/$m4kmA6S99tc1Eq.wi5ZTW1' and I get the exact same error, just different local Variables in the backtrace. Not sure what to do about this.

install
url --url http://mirror.fiber.net/fedora-11
lang en_US.UTF-8
keyboard us
reboot
network --device=eth0 --bootproto=static --ip=69.168.70.66 --netmask=255.255.255.192 --gateway=69.168.70.65 --nameserver=216.83.130.2 --hostname=fedora-test
rootpw hisd89jfjiei
firewall --disabled
firstboot --disable
authconfig --enableshadow --enablemd5
selinux --disabled
timezone --utc America/Boise
bootloader --location=mbr --driveorder=sda
clearpart --all --initlabel --linux
part / --fstype ext3 --size=1 --grow --asprimary

%packages
@core
@base
%end

%post
useradd -p '$1$0D9xXtg0$.yEXR06qCEzEECQI2T3UE.' kai
usermod -p '$1$MJGn1di/$m4kmA6S99tc1Eq.wi5ZTW1' root
%end
Comment 3 Kai Meyer 2009-07-07 12:40:16 EDT
Sorry, I should be more careful. This ocurred because I was booting off of the Fedora-10 netinst ISO instead of the Fedora-11 one. I think I would prefer to have the bleeding error about the repository mismatching the installation media rather than having this sort of chase to worry about.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.