Bug 510098 - Libxcb-devel.x86_64 depends on i586 packages
Libxcb-devel.x86_64 depends on i586 packages
Status: CLOSED DUPLICATE of bug 510088
Product: Fedora
Classification: Fedora
Component: libxcb (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 12:53 EDT by Martin Kho
Modified: 2009-07-07 14:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-07 13:46:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kho 2009-07-07 12:53:05 EDT
Description of problem:
libxcb-devel depends on:
* glibc.i686
* libXau.i586
* libxcb.i586
* nss-softokn-freebl.i586

This looks not right.

Version-Release number of selected component (if applicable):
libxcb-devel.1.2-3.fc11.x86_64 (rawhide)

How reproducible:
On a x86_64 system run: yum install libxcb-devel

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Transaction Check Error:
package libxcb-1.2-4.fc11.x86_64 (which is newer than libxcb-1.2-3.fc11.i586) is already installed

Expected results:
libxcb-devel.x86_64 installed

Additional info:
Comment 1 Rex Dieter 2009-07-07 13:46:09 EDT
This is false, though the deps could be tightened using %_isa

For you, since you have multilib'd libxcb installed already, 
yum install libxcb.i586 libxcb.x86_64 libxcb-devel
will (likely) work better (since you have an older libxcb.i586 installed).
Comment 2 Martin Kho 2009-07-07 14:13:10 EDT
Hi Rex,

See also my response on bug #510088. I've no i586 packages.

Any suggestions?

Regards,

Martin Kho
Comment 3 Martin Kho 2009-07-07 14:25:42 EDT
Hi,

On my system is libxcb-1.2-4.fc11.x86_64 installed and yum 'wants' to install libxcb-devel-1.2-3.fc11.x86_64. An older devel version?

Martin Kho
Comment 4 Rex Dieter 2009-07-07 14:42:40 EDT

*** This bug has been marked as a duplicate of bug 510088 ***

Note You need to log in before you can comment on or make changes to this bug.