Bug 510101 - X crashes with Mathematica
X crashes with Mathematica
Status: CLOSED DUPLICATE of bug 512693
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 13:18 EDT by Arjan
Modified: 2009-09-09 10:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-09 10:59:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (52.92 KB, text/plain)
2009-07-07 13:18 EDT, Arjan
no flags Details

  None (edit)
Description Arjan 2009-07-07 13:18:09 EDT
Created attachment 350837 [details]
Xorg.0.log

Description of problem: X crashes when scrolling through a certain Mathematica notebook

How reproducible: Always

Steps to Reproduce:
1. Open notebook
2. Start scrolling
3. Crash
  
Actual results: Crash

Expected results: No Crash

Additional info:

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x26) [0x4e89b6]
1: /usr/bin/Xorg(xf86SigHandler+0x6f) [0x47d63f]
2: /lib64/libc.so.6 [0x31fd233370]
3: /usr/lib64/dri/i965_dri.so(intelDestroyContext+0x139) [0x7f125eaa50c5]
4: /usr/lib64/dri/i965_dri.so [0x7f125ea9d886]
5: /usr/lib64/xorg/modules/extensions//libglx.so [0x7f1260493969]
6: /usr/lib64/xorg/modules/extensions//libglx.so(__glXFreeContext+0x6c) [0x7f126048959c]
7: /usr/lib64/xorg/modules/extensions//libglx.so [0x7f12604895d3]
8: /usr/bin/Xorg(FreeResourceByType+0x11f) [0x42ee8f]
9: /usr/lib64/xorg/modules/extensions//libglx.so [0x7f1260485e8e]
10: /usr/lib64/xorg/modules/extensions//libglx.so [0x7f1260489839]
11: /usr/bin/Xorg(Dispatch+0x384) [0x446ee4]
12: /usr/bin/Xorg(main+0x3b5) [0x42d0d5]
13: /lib64/libc.so.6(__libc_start_main+0xfd) [0x31fd21ea2d]
14: /usr/bin/Xorg [0x42c559]

Fatal server error:
Caught signal 11.  Server aborting
Comment 1 Arjan 2009-07-08 07:43:33 EDT
Okay, this only happens when scrolling over 3D graphics. Alternative steps to reproduce:

1. Open notebook
2. Evaluate something like: Plot3D[x+y, {x,-1,1}, {y,-1,1}]
3. X crashes

This problem does not occur when starting mathematica with the -vesa option, see:

http://ubuntuforums.org/showthread.php?t=610872
Comment 2 Bastien Nocera 2009-09-09 10:59:11 EDT
Closing as a dupe of bug 512693 which has more comments, and doesn't require using a proprietary app to reproduce.

*** This bug has been marked as a duplicate of bug 512693 ***

Note You need to log in before you can comment on or make changes to this bug.