Bug 510137 - gpk-application gives no error if user doesn't have install privileges, just does nothing
gpk-application gives no error if user doesn't have install privileges, just ...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 16:25 EDT by Jón Fairbairn
Modified: 2010-03-22 12:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-22 12:01:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jón Fairbairn 2009-07-07 16:25:58 EDT
Description of problem:
Having granted myself org.freedesktop.packagekit.system-update
I didn't notice and didn't give myself org.freedesktop.packagekit.package-install. Later when I tried to use gpk-application to install an application The "Apply" button lit up, so I clicked on it. It went through some of the stages (getting information; resolving dependencies) and then simply stopped with the "Apply" button lit up.

Version-Release number of selected component (if applicable):
gnome-packagekit-2.27.2-1.fc11.x86_64

How reproducible:
Completely


Steps to Reproduce:
1. Connect from a non-console session
2. If you already have org.freedesktop.packagekit.package-install, use polkit-auth to revoke it
3. start gpk-application
4. select a package that isn't already installed
5. click on apply
  
Actual results:
some blinkenlights and then back to stage 5

Expected results:
an error dialogue box that complains that the user is not authorised to install packages (ideally mentioning org.freedesktop.packagekit.package-install)

Additional info:
This sort of thing is why I still tend to type "sudo yum install ..."
Comment 1 Steven M. Parrish 2009-07-22 10:36:40 EDT
Richard,  Comments, questions?

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Richard Hughes 2009-07-23 14:06:37 EDT
We've fixed this in rawhide using PolicyKit1, but I'm not sure about 0.4.x -- looks like we'll have to code up the same fallback.
Comment 3 Steven M. Parrish 2009-09-29 09:50:08 EDT
Richard, any movement on this issue?

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Jón Fairbairn 2010-01-16 05:22:09 EST
Trying this in Fedora 12, I get an error box, so I think this should be closed nextrelease, though the error box probably should say "not authorized" rather than "authorization failed ... you have failed to provide correct authentication" given that one is given no opportunity to provide it.

Note You need to log in before you can comment on or make changes to this bug.