Bug 510155 - Xserver man page included in four different packages
Xserver man page included in four different packages
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 18:12 EDT by Mark Gordon
Modified: 2013-11-05 13:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-05 13:59:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Gordon 2009-07-07 18:12:13 EDT
Description of problem:
Four different packages provide the Xserver man page.  If the content changes (as it did recently), then all the packages that provide the new version of the man page need to be updated simultaneously in order to avoid file conflicts.  This implicit dependency isn't terribly intuitive, and there are better ways of doing this.

Version-Release number of selected component (if applicable):
e.g. upgrade to 1.1.1-48.65 from 1.1.1-48.52

How reproducible:
Always

Steps to Reproduce:
1. Attempt to upgrade e.g. xorg-x11-server-Xorg (all by itself, with no other packages) from the 5.3 version (with other packages containing the Xserver man page installed) to the 5.4 version.
  
Actual results:
man page conflict with other xorg-x11-server packages (e.g. xorg-x11-server-Xnest, varies with what you have installed)

Expected results:
At the very least, a more clear error message.

Additional info:
Current Fedora has the man pages split off into a common package that's a requirement of all the other packages.  This seems like a better approach moving forward.

It's a bit late to make such a change for 5.4, especially since it won't be a problem under typical upgrade scenarios, but some explanation in the release notes seems to be in order.

For the record, the Xserver man page is currently packaged in:
xorg-x11-server-Xdmx
xorg-x11-server-Xephyr
xorg-x11-server-Xnest
xorg-x11-server-Xorg
Comment 4 RHEL Product and Program Management 2012-10-30 01:51:07 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 Adam Jackson 2013-11-05 13:59:46 EST
Not critical enough to fix in RHEL5, closing.

Note You need to log in before you can comment on or make changes to this bug.