Bug 510203 - exim installation, error in %post, chown: cannot access `/etc/pki/tls/private/exim.pem'
exim installation, error in %post, chown: cannot access `/etc/pki/tls/privat...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: exim (Show other bugs)
5.4
All Linux
high Severity high
: rc
: ---
Assigned To: Miroslav Lichvar
BaseOS QE
: Reopened
Depends On:
Blocks: 500798
  Show dependency treegraph
 
Reported: 2009-07-08 06:58 EDT by Petr Sklenar
Modified: 2013-04-12 16:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-02 07:15:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1627 normal SHIPPED_LIVE exim bug fix update 2009-12-02 07:15:07 EST

  None (edit)
Description Petr Sklenar 2009-07-08 06:58:55 EDT
Description of problem:
missing files during installation of exim to external root (maybe into normal root)

Version-Release number of selected component (if applicable):
exim-4.63-3.el5.x86_64
rhel54-Server-20090708.nightly

How reproducible:
always

Steps to Reproduce:
1. yum --installroot=/tmp/tmp.sfPCdk6328 install exim -y --disablerepo=\*rhts-noarch\* 
  
Actual results:
....
  Installing     : rsyslog                                         [66/71] 
  Installing     : initscripts                                     [67/71] 
  Installing     : exim                                            [68/71] 
chown: cannot access `/etc/pki/tls/private/exim.pem': No such file or directory
chown: cannot access `/etc/pki/tls/certs/exim.pem': No such file or directory
chmod: cannot access `/etc/pki/tls/private/exim.pem': No such file or directory
chmod: cannot access `/etc/pki/tls/certs/exim.pem': No such file or directory
error: %post(exim-4.63-3.el5.x86_64) scriptlet failed, exit status 1
  Installing     : mcstrans                                        [69/71] 
  Installing     : python                                          [70/71] 
  Installing     : cracklib                                        [71/71] 
....

-----------------
no files in /tmp/tpm.sfPCdk6328/etc/pki/tls/certs/exim.pem
/tmp/tpm.sfPCdk6328/etc/pki/tls/private/exim.pem


Expected results:
clear installation of exim

Additional info:
# rpm -ivh /mnt/redhat/brewroot/packages/exim/4.63/3.el5/x86_64/exim-4.63-3.el5.x86_64.rpm --root=/tmp/tmp.sfPCdk6328 --replacepkgs
warning: /mnt/redhat/brewroot/packages/exim/4.63/3.el5/x86_64/exim-4.63-3.el5.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 897da07a
Preparing...                ########################################### [100%]
   1:exim                   ########################################### [100%]
chown: cannot access `/etc/pki/tls/private/exim.pem': No such file or directory
chown: cannot access `/etc/pki/tls/certs/exim.pem': No such file or directory
chmod: cannot access `/etc/pki/tls/private/exim.pem': No such file or directory
chmod: cannot access `/etc/pki/tls/certs/exim.pem': No such file or directory
error: %post(exim-4.63-3.el5.x86_64) scriptlet failed, exit status 1
Comment 1 Miroslav Lichvar 2009-08-12 08:04:16 EDT

*** This bug has been marked as a duplicate of bug 515553 ***
Comment 2 Radek Bíba 2009-08-24 06:02:11 EDT
Re-opening, this isn't really a dupe of 515553.
Comment 4 Miroslav Lichvar 2009-08-25 04:34:46 EDT
Bug #517013 is corresponding Fedora bug.
Comment 10 errata-xmlrpc 2009-12-02 07:15:10 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1627.html

Note You need to log in before you can comment on or make changes to this bug.