Bug 510246 - qt package contains broken link to qt-devel
qt package contains broken link to qt-devel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 511320 (view as bug list)
Depends On: 513224
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-08 09:21 EDT by Lubomir Rintel
Modified: 2009-08-20 17:01 EDT (History)
8 users (show)

See Also:
Fixed In Version: 4.5.2-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-20 17:00:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Rintel 2009-07-08 09:21:40 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Lubomir Rintel 2009-07-08 09:24:59 EDT
whoops; hit enter too soo.

Description of problem:

$ rpm -qf /usr/lib/libQtCore.so.4
qt-4.5.1-13.fc11.i586
$ file /usr/lib/libQtCore.so.4
/usr/lib/libQtCore.so.4: broken symbolic link to `libQtCore_debug.so'

Version-Release number of selected component (if applicable):

qt-4.5.1-13.fc11.i586

Additional info:

This breaks the VirtualBox-OSE package:
https://bugzilla.rpmfusion.org/show_bug.cgi?id=710

"repoquery --whatrequires libQtCore.so.4" lists 413 for me.
Comment 2 Rex Dieter 2009-07-08 10:04:44 EDT
I don't see that here,

$ file /usr/lib/libQtCore.so.4
/usr/lib/libQtCore.so.4: symbolic link to `libQtCore.so.4.5.1'

$ rpm -q -f /usr/lib/libQtCore.so.4 /usr/lib/libQtCore.so.4.5.1
qt-4.5.1-13.fc11.i586
qt-4.5.1-13.fc11.i586
Comment 3 Rex Dieter 2009-07-08 10:07:30 EDT
For details on the origin of the _debug symlinks, see bug #196513
Comment 4 Rex Dieter 2009-07-08 10:08:31 EDT
And, for completeness, 

$ file /usr/lib/libQtCore_debug.so
/usr/lib/libQtCore_debug.so: symbolic link to `libQtCore.so'

$ rpm -q -f /usr/lib/libQtCore_debug.so /usr/lib/libQtCore.so
qt-devel-4.5.1-13.fc11.i586
qt-devel-4.5.1-13.fc11.i586
Comment 5 Lubomir Rintel 2009-07-08 10:29:08 EDT
You're right, rpm -V says the actual symlink targets don't match what's in the package. I have never touched the qt installation, so I really don't understand why the links point the other way.

The timestamp of the link suggests that it was created on Jun 17, 13:18.

[root@trurl dege]# stat /usr/lib/libQtCore.so.4
  File: `/usr/lib/libQtCore.so.4' -> `libQtCore_debug.so'
  Size: 18        	Blocks: 0          IO Block: 4096   symbolic link
Device: fd03h/64771d	Inode: 52725       Links: 1
Access: (0777/lrwxrwxrwx)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2009-07-07 16:58:49.058718622 +0200
Modify: 2009-06-17 13:18:36.178524092 +0200
Change: 2009-06-17 13:18:36.178524092 +0200
[root@trurl dege]# 

At that time, and update seems to have been running, which updated qt according to the yum log:

Jun 17 13:18:30 Updated: libX11-1.2.1-2.fc11.i586
Jun 17 13:18:31 Updated: 2:qemu-common-0.10.5-2.fc11.i586
Jun 17 13:18:32 Updated: ibus-libs-1.1.0.20090609-1.fc11.i586
Jun 17 13:18:36 Updated: 1:qt-4.5.1-13.fc11.i586
Jun 17 13:18:37 Updated: file-libs-5.03-2.fc11.i586
Jun 17 13:18:41 Updated: DeviceKit-power-008-1.fc11.i586
Jun 17 13:18:41 Updated: file-5.03-2.fc11.i586
Jun 17 13:18:55 Updated: 1:qt-x11-4.5.1-13.fc11.i586
...

qt-devel was updated some time later:

...
Jun 17 13:23:05 Updated: 1:qt-devel-4.5.1-13.fc11.i586

Maybe the symlink was in place before and RPM dereferenced it when unpacking the CPIO payload?
Comment 6 Rex Dieter 2009-07-08 10:40:13 EDT
loads of awesome,

$ yum install qt-devel

$ rpm -e qt-devel

$ file /usr/lib/libQtcore.so.4
/usr/lib/libQtcore.so.4: cannot open `/usr/lib/libQtcore.so.4' (No such file or directory)

$ sudo /sbin/ldconfig

$ file /usr/lib/libQtCore.so.4
/usr/lib/libQtCore.so.4: symbolic link to `libQtCore.so.4.5.1'


Something wierd and freaky is going on... -devel scriptlets?
Comment 7 Rex Dieter 2009-07-08 10:46:19 EDT
Nevermind, I can't read, libQtcore.so.4 != libQtCore.so.4

So, still can't reproduce.
Comment 8 Rex Dieter 2009-07-08 10:48:29 EDT
Back to square one, if we can come up with a recipe to reproduce this, that would greatly help.
Comment 9 Rex Dieter 2009-07-14 23:07:57 EDT
*** Bug 511320 has been marked as a duplicate of this bug. ***
Comment 10 Göran Uddeborg 2009-07-15 15:03:51 EDT
I managed to reproduce it.  What I did was to back down to the original F11 version of qt (using rpm --oldpackage ...):

mimmi$ rpm -V qt qt-x11                                                         mimmi$ rpm -qa qt\*
qt-4.5.0-14.fc11.x86_64
qt3-3.3.8b-12.fc9.i386
qt-x11-4.5.0-14.fc11.x86_64
qt-devel-4.5.0-14.fc11.x86_64
qt-mysql-4.5.0-14.fc11.x86_64
qt3-3.3.8b-12.fc9.x86_64

The I upgrade again:

mimmi$ sudo env LANG=en_US.utf8 yum upgrade qt
...
Updated:
  qt.x86_64 1:4.5.1-13.fc11                                                     

Dependency Updated:
  qt-devel.x86_64 1:4.5.1-13.fc11        qt-mysql.x86_64 1:4.5.1-13.fc11       
  qt-x11.x86_64 1:4.5.1-13.fc11         


After this, the links are broken:

mimmi$ rpm -V qt qt-x11
....L....    /usr/lib64/libQtCore.so.4
....L....    /usr/lib64/libQtDBus.so.4
....L....    /usr/lib64/libQtNetwork.so.4
....L....    /usr/lib64/libQtScript.so.4
....L....    /usr/lib64/libQtSql.so.4
....L....    /usr/lib64/libQtTest.so.4
....L....    /usr/lib64/libQtXml.so.4
....L....    /usr/lib64/libQtXmlPatterns.so.4
....L....    /usr/lib64/libQt3Support.so.4
....L....    /usr/lib64/libQtAssistantClient.so.4
....L....    /usr/lib64/libQtCLucene.so.4
....L....    /usr/lib64/libQtDesigner.so.4
....L....    /usr/lib64/libQtDesignerComponents.so.4
....L....    /usr/lib64/libQtGui.so.4
....L....    /usr/lib64/libQtHelp.so.4
....L....    /usr/lib64/libQtOpenGL.so.4
....L....    /usr/lib64/libQtScriptTools.so.4
....L....    /usr/lib64/libQtSvg.so.4
....L....    /usr/lib64/libQtWebKit.so.4
Comment 11 Rex Dieter 2009-08-05 15:26:03 EDT
Seems to be the combination of odd rpm scriptlet ordering and ldconfig behavior, see also bug #513224 , and ongoing discussion on packaging list:
https://www.redhat.com/archives/fedora-packaging/2009-August/msg00012.html
Comment 12 Rex Dieter 2009-08-05 15:56:31 EDT
Neat, notting suggested on irc that I look into qt using linker scripts instead of lib*_debug.so symlinks.  It appears to be a much cleaner and safer solution... off to test it out.
Comment 13 Rex Dieter 2009-08-05 21:14:20 EDT
Worked like a charm, here's the builds for the curious:

F-10: https://koji.fedoraproject.org/koji/buildinfo?buildID=125929
F-11: https://koji.fedoraproject.org/koji/buildinfo?buildID=125907

An update will be prepared shortly.
Comment 14 Fedora Update System 2009-08-07 08:13:00 EDT
qt-4.5.2-1.fc11.1 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qt-4.5.2-1.fc11.1
Comment 15 Fedora Update System 2009-08-07 08:13:53 EDT
qt-4.5.2-1.fc10.1 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/qt-4.5.2-1.fc10.1
Comment 16 Fedora Update System 2009-08-08 15:31:06 EDT
qt-4.5.2-1.fc10.1 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8398
Comment 17 Fedora Update System 2009-08-08 15:32:54 EDT
qt-4.5.2-1.fc11.1 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8406
Comment 18 Fedora Update System 2009-08-17 17:53:20 EDT
qt-4.5.2-1.fc10.2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8398
Comment 19 Fedora Update System 2009-08-17 18:04:00 EDT
qt-4.5.2-1.fc11.2 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8406
Comment 20 Fedora Update System 2009-08-18 09:47:36 EDT
qt-4.5.2-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qt-4.5.2-2.fc11
Comment 21 Fedora Update System 2009-08-18 09:52:59 EDT
qt-4.5.2-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/qt-4.5.2-2.fc10
Comment 22 Fedora Update System 2009-08-20 17:00:34 EDT
qt-4.5.2-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Fedora Update System 2009-08-20 17:01:14 EDT
qt-4.5.2-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.