Bug 510258 - tiffcp options differ in program help and manual page
tiffcp options differ in program help and manual page
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libtiff (Show other bugs)
7.0
All Linux
medium Severity medium
: beta
: 7.0
Assigned To: Jaromír Končický
Miroslav Vadkerti
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-08 10:04 EDT by Miroslav Vadkerti
Modified: 2014-06-18 04:46 EDT (History)
4 users (show)

See Also:
Fixed In Version: libtiff-4.0.3-8.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:12:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Vadkerti 2009-07-08 10:04:14 EDT
Description of problem:
tiffcp's program help contains some options unexplained in manual page and some options in manual page are not present in program help. 
3 option(s) reported by the program ONLY:
	-a
	-i
	-o
5 option(s) reported by the man page ONLY:
	-1
	-B
	-C
	-L
	-M

Version-Release number of selected component (if applicable):
libtiff-3.8.2-7.el5_3.3
libtiff-3.6.1-12.el4_8.3
libtiff-3.5.7-32.el3


How reproducible:
always

Steps to Reproduce:
1. tiffcp -h
2. man tiffcp
3. compare options
  
Actual results:
There are differences between program help and manual pages.

Expected results:
No differences

Additional info:
This bug also appears in RHEL-3 and RHEL-4
Comment 1 Tom Lane 2013-03-05 22:39:25 EST
I've fixed this upstream, so it should appear in RHEL7, but I don't think we will bother anymore to fix it in RHEL5.
Comment 2 Miroslav Vadkerti 2013-03-06 03:42:05 EST
I think this bug could be moved to RHEL7 and should be tested by QE, reopenning.
Tom can we get a NVR of the fixed EL7 build please?
Comment 3 Miroslav Vadkerti 2013-08-12 04:28:57 EDT
Moving back to assigned. Still not fixed in current RHEL7 release libtiff-4.0.3-6.el7.
Comment 4 Miroslav Vadkerti 2013-08-12 04:33:39 EDT
I will test this bug. Testing is easy with options comparator. Cover in TCMS together with bug 510240.
Comment 6 Miroslav Vadkerti 2013-10-01 03:27:27 EDT
Thanks for the fixes, looks like the only one left missing is:

1 option(s) reported by the program ONLY:
        -8

I do not see this explained in the **man page**.
Comment 8 Petr Hracek 2013-10-08 04:26:58 EDT
cvs-commit (http://bulk-mail.corp.redhat.com/archives/cvs-commits-list/2013-October/msg02285.html) -> MODIFIED
Comment 11 Ludek Smid 2014-06-13 07:12:56 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.