Bug 51027 - RFE: enhance loader to use 'nextserver' and 'bootfile' fields from dhcp to get kickstart file with http
Summary: RFE: enhance loader to use 'nextserver' and 'bootfile' fields from dhcp to ge...
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 9
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-06 18:23 UTC by bruno
Modified: 2008-01-17 17:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:48:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description bruno 2001-08-06 18:23:25 UTC
Description of problem:
to get the kickstart file with http, a user has to supply the entire URL.
loader should be enhanced to get the servername and filename from dhcp and
construct the URL with these values (like the NFS method).

How reproducible:
Always

Steps to Reproduce:
it's great that loader can now get the kickstart file with http, but it
requires that user input the URL on the syslinux.cfg command line. (the
code segment below shows that the function kickstartFromHttp() will return
if no kickstart file is supplied).

================================================
current kickstartFromHttp()
================================================
    if (ksSource) {
        ksPath = alloca(strlen(ksSource) + 1);
        strcpy(ksPath, ksSource);
    } else {
        logMessage("no location specified");
        return 1;
    }
================================================


it would be better if loader could build a URL from the dhcp response if no
URL is specified.

================================================
potential enhancement to kickstartFromHttp()
================================================
    if (ksSource) {
        ksPath = alloca(strlen(ksSource) + 1);
        strcpy(ksPath, ksSource);
    } else {
        /*
         * build the path to the kickstart file from the DHCP response
         */
        ksPath = alloca(strlen(file) +
                        strlen(inet_ntoa(netDev.dev.nextServer)) + 70);
        strcpy(ksPath, inet_ntoa(netDev.dev.nextServer));
        strcat(ksPath, file);
    }
=============================================

Comment 1 Michael Fulbright 2001-08-06 22:31:25 UTC
Sounds like a feature request to consider for future releases.

Comment 2 Michael Fulbright 2002-03-26 17:45:22 UTC
Deferring to future release.

Comment 3 Red Hat Bugzilla 2006-02-21 18:48:04 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.