Bug 510273 - clustered lvm snapshots don't work
clustered lvm snapshots don't work
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Documentation-cluster (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Steven J. Levine
Content Services Development
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-08 10:48 EDT by Issue Tracker
Modified: 2010-10-23 06:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-03 12:25:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2009-07-08 10:48:37 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2009-07-08 10:48:38 EDT
Event posted on 06-09-2009 05:04am EDT by khabarov

Hello!

My question is related with the documentation. 
As it is described here:
http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/Cluster_Logical_Volume_Manager/snapshot_command.html
One, can create an LVM snapshot from clustered logical volume. If you follow this, you'll get that Clustered snapshots are not yet implemented. 
It is OK, that clustered snapshots are not yet implemented, but I guess, that there is an error at the documentation. It should describe the situation in a better way.

Could you please comment this.

Thx!

With Best Regards,
Konst
This event sent from IssueTracker by dejohnso  [Support Engineering Group]
 issue 305275
Comment 2 Issue Tracker 2009-07-08 10:48:40 EDT
Event posted on 06-09-2009 10:41am EDT by khabarov

Hi Marko!

Sorry for so short report.

Steps to reproduce:

1) Setup two node cluster with shared storage (I used xen)
2) Change locking type for lvm
3) Start cluster services (cman + clvmd)
4) Create physical volume on that storage
# pvcreate /dev/xvdc1
5) Create a vg
# vgcreate -c y test_snap /dev/xvdc1
6) Create lv
# lvcreate -n base -L 500M test_snap
7) restart clvmd on another node to update the lvm metadata
8) make the newly created lv exclusively for one node
# lvchange -a ey /dev/mapper/test_snap-base
9) Try to create lvm snapshot 
# lvcreate -s -n snap -v -L 500M test_snap/base

At this step you'll get this message:

Setting chunksize to 8 sectors.
Setting logging type to disk
Finding volume group "test_snap"
Clustered snapshots are not yet supported.

I guess that the problem is that message... I followed documentation and
faced with it. 

Do you need any additional info from me?

WBR,
Konst


Internal Status set to 'Waiting on Support'
Status set to: Waiting on Tech

This event sent from IssueTracker by dejohnso  [Support Engineering Group]
 issue 305275
Comment 3 Issue Tracker 2009-07-08 10:48:42 EDT
Event posted on 07-06-2009 07:52am EDT by mkpai


SEG Escalation Template

All Issues: Problem Description
---------------------------------------------------
1. Time and date of problem:

Misleading documentation.

2. System architecture(s):

All.

3. Provide a clear and concise problem description as it is understood at
the time of escalation. Please be as specific as possible in your
description. Do not use the generic term "hang", as that can mean many
things.

   Observed behavior:

http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/Cluster_Logical_Volume_Manager/snapshot_command.html

does not warn that snapshots of clustered volumes are not supported.

   Desired behavior:

http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/Cluster_Logical_Volume_Manager/snapshot_command.html

should warn that snapshots of clustered volumes are not supported.


4. Specific action requested of SEG:

a. Kindly recommend to the documentation team that
http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/Cluster_Logical_Volume_Manager/snapshot_command.html
should warn  that snapshots of clustered volumes are not supported.

b. Kindly also review the status of BZ 180262 which is for RHEL 6. Can we
assure the customer that support for snapshots of clustered volumes will
be available for RHEL 6 GA ?

5. Is a defect (bug) in the product suspected? yes/no

Defect in documentation.

6. Does a proposed patch exist? yes/no
   If yes, attach patch, making sure it is in unified diff format (diff
-pruN)

Not applicable




Issue escalated to Support Engineering Group by: mkpai.
Internal Status set to 'Waiting on SEG'

This event sent from IssueTracker by dejohnso  [Support Engineering Group]
 issue 305275
Comment 4 Paul Kennedy 2009-07-08 10:59:18 EDT
Reassigning to slevine, primary writer for LVM
Comment 5 Steven J. Levine 2009-07-15 16:35:47 EDT
The fact that snapshot volumes are not supported for clustered volumes is noted a couple of times in the manual, but I need to make that information more clear

- Currently in section 2.3.4 of the LVM document, when snapshots are described in general, there is a Note indicating that LVM snapshots are not supported across the nodes in a cluster. It might be better if I simply said that snapshots of clustered volumes are not supported.

- In section 4.5, the section referenced in this bug, the second paragraph reads:

> LVM snapshots are not cluster-aware, so they require exclusive access to a volume. For information on activating logical volumes on individual nodes in a cluster, see Section 4.8, “Activating Logical Volumes on Individual Nodes in a Cluster”. 

So obviously I need to clarify that as well -- and bring the information more to the surface. I think, again, a note saying something simple like "Snapshots of clustered volumes are not supported."

I will add this for RHEL 5.4.
Comment 6 Aleksander Trofimowicz 2009-08-05 03:55:13 EDT
Fine, Steven. You can change the section 4.5 that way. But can you explain the meaning of the section 4.8 then? Hint: the solution presented in the latter is utterly wrong.

To me in a case of creating snapshots exclusivity of clustered LV has never worked at all.
Comment 7 Steven J. Levine 2009-08-07 14:31:21 EDT
Alexsander:

I'm not sure what I need to fix in Section 4.8 of the LVM manual. Currently that section reads as follows:
---------------

4.8. Activating Logical Volumes on Individual Nodes in a Cluster

If you have LVM installed in a cluster environment, you may at times need to activate logical volumes exclusively on one node. For example, the pvmove command is not cluster-aware and needs exclusive access to a volume. LVM snapshots require exclusive access to a volume as well.

To activate logical volumes exclusively on one node, use the lvchange -aey command. Alternatively, you can use lvchange -aly command to activate logical volumes only on the local node but not exclusively. You can later activate them on additional nodes concurrently.

You can also activate logical volumes on individual nodes by using LVM tags, which are described in Appendix C, LVM Object Tags. You can also specify activation of nodes in the configuration file, which is described in Appendix B, The LVM Configuration Files. 
--------

Is it the sentence about LVM snapshots requiring exclusive access to a volume, or the lvchange command options that are misleading or incorrect?

Thanks,

-Steven
Comment 8 Aleksander Trofimowicz 2009-08-12 04:28:11 EDT
Both. See steps #8 and #9 at comment 2. Despite Kontstantin requested exclusive access to a volume, the last command failed.

Currently IMHO the only way to get snapshot is to turn clustered locking on a given volume group off. Moreover as long as a snapshot resides on that VG, you cannot enable clustered locking again.
Comment 11 Jonathan Earl Brassow 2009-08-14 17:35:35 EDT
cluster snapshots will not work in a cluster for RHEL5.

Even if you only activate the snapshot on one machine, the snapshot will be corrupted when other machines in the cluster write to the origin.  So, no cluster snapshots.
Comment 12 Steven J. Levine 2009-08-17 14:01:24 EDT
It is true that you cannot create a snapshot volume in a clustered volume group, even if you activate the volume exclusively on one node. I have added a sentence to the note regarding no snapshot support in a cluster:

> LVM snapshots are not supported across the nodes in a cluster.
> You cannot create a snapshot volume in a clustered volume group.

In addition, I have removed the sentence from section 4.8 about snapshot volumes requiring exclusive access to a volume, since that was misleading. These changes should be in effect for the RHEL 5.4 release.
Comment 13 Steven J. Levine 2009-09-03 12:25:08 EDT
With the release of RHEL 5.4 I am closing this bug.

Note You need to log in before you can comment on or make changes to this bug.