Bug 510302 - Installation bricht ab
Installation bricht ab
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:d39cb5a14d34d22ff...
: Reopened
: 511272 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-08 11:56 EDT by Stefan Ringel
Modified: 2009-07-20 10:59 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 511272 511903 (view as bug list)
Environment:
Last Closed: 2009-07-20 10:59:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (132.24 KB, text/plain)
2009-07-08 11:57 EDT, Stefan Ringel
no flags Details
Attached traceback automatically from anaconda. (107.22 KB, text/plain)
2009-07-10 21:10 EDT, Geoff Levand
no flags Details
Attached traceback automatically from anaconda. (96.45 KB, text/plain)
2009-07-11 21:15 EDT, Dave Jones
no flags Details
Attached traceback automatically from anaconda. (108.15 KB, text/plain)
2009-07-13 20:16 EDT, Geoff Levand
no flags Details
X-Server mit Schnee! (93.02 KB, text/plain)
2009-07-14 12:22 EDT, Stefan Ringel
no flags Details
Attached traceback automatically from anaconda. (266.01 KB, text/plain)
2009-07-14 17:06 EDT, Adam Jackson
no flags Details

  None (edit)
Description Stefan Ringel 2009-07-08 11:56:58 EDT
The following was filed automatically by anaconda:
anaconda 12.1 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/isys.py", line 660, in matchPathContext
    return _isys.matchPathContext(fn)
  File "/usr/lib/anaconda/isys.py", line 675, in resetFileContext
    con = matchPathContext(fn)
  File "/usr/lib/anaconda/storage/formats/fs.py", line 570, in mount
    ret = isys.resetFileContext(mountpoint, chroot)
  File "/usr/lib/anaconda/storage/formats/fs.py", line 799, in setup
    return self.mount(**kwargs)
  File "/usr/lib/anaconda/storage/__init__.py", line 1636, in mountFilesystems
    chroot=anaconda.rootPath)
  File "/usr/lib/anaconda/packages.py", line 201, in turnOnFilesystems
    skipRoot=anaconda.backend.skipFormatRoot)
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1346, in nextClicked
    self.anaconda.dispatch.gotoNext()
AttributeError: 'module' object has no attribute 'matchPathContext'
Comment 1 Stefan Ringel 2009-07-08 11:57:06 EDT
Created attachment 350961 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-07-08 11:59:27 EDT
This will be fixed in the next build of anaconda.  Thanks for the bug report.
Comment 3 Geoff Levand 2009-07-10 21:10:32 EDT
Created attachment 351315 [details]
Attached traceback automatically from anaconda.
Comment 4 Dave Jones 2009-07-11 21:15:18 EDT
Created attachment 351366 [details]
Attached traceback automatically from anaconda.
Comment 5 Geoff Levand 2009-07-13 20:15:45 EDT
Just to report, this is still hit in today's rawhide build (13-Jul-2009 15:48) with anaconda 12.2.

-Geoff
Comment 6 Geoff Levand 2009-07-13 20:16:08 EDT
Created attachment 351540 [details]
Attached traceback automatically from anaconda.
Comment 7 Stefan Ringel 2009-07-14 10:01:56 EDT
15:52:19 ERROR   : Error running xrandr: None
15:52:19 ERROR   : Exception when running xrandr: Error running xrandr: None

??
Comment 8 Chris Lumens 2009-07-14 10:38:00 EDT
*** Bug 511272 has been marked as a duplicate of this bug. ***
Comment 9 Chris Lumens 2009-07-14 11:20:41 EDT
I'm not seeing this with yesterday's rawhide and anaconda 12.2.
Comment 10 Stefan Ringel 2009-07-14 12:22:44 EDT
Created attachment 351624 [details]
X-Server mit Schnee!

in german:

In normalen Installationsmodus startet der X server zwar, aber mit einem Schnee-Bildschirm! (Attachment)

In abgesicherten Grafik-Installationsmodus bricht die Installation ab (siehe erstes Bug-Report)

Stefan Ringel
Comment 11 Adam Jackson 2009-07-14 17:06:07 EDT
Created attachment 351694 [details]
Attached traceback automatically from anaconda.
Comment 12 Chris Lumens 2009-07-17 14:44:08 EDT
Please stop reopening this bug with xrandr problems.  This bug tracks the traceback shown in the initial comment.  Thanks.
Comment 13 Stefan Ringel 2009-07-18 13:21:42 EDT
in german:

Ich habe heute nochmals versucht mit den gleichen Installationsmedien zu installieren. Beim letzen mal (Erstmeldung dieses Bugs #510302) hatte ich das ext4-Dateisystem benutzt. Jetzt versuchte ich es mit dem ext3-Dateisystem und ich konntees zu Ende installieren. Das xrandr Problem bleibt aber weiterhin bestehen und ist nicht die Ursache dieses Bugs. Zudem trat ein weiteres Problem auf als ich mehrmals vergessen hatte die Partitionen zu loeschen, was zur Folge hatte, dass ich den Bug #510966 hatte. 
Ich denke, dass dieses Bug mit dem ext4 in Beziehung steht.
Ab Kernel 2.6.31 rc3 sind diverse Bugfixe zum ext4-Dateisystem enthalten, die moeglicherweise dieses Bug beheben koennten.

Stefan Ringel
Comment 14 Stefan Ringel 2009-07-18 15:10:48 EDT
in german:

Zusatz zu meinen letzten Kommetar: Bug #512063 schildert das gleiche Problem mit der ext4-Partition.
Comment 15 Andy Lindeberg 2009-07-20 10:59:06 EDT
Oh boy...

Ich kann ein bisschen Deutsch, aber ich bin nicht fließend...

Ihr originales Problemreport ist fixiert worden. Andere Probleme sollten ihre eigenen Problemreports haben. Wir wissen, dass der ext4-Dateisystem ein Problem ist.

Wenn Sie andere Probleme sehen, bitte öffnen Sie einen neuen Problemreport für jedes.

Note You need to log in before you can comment on or make changes to this bug.