Bug 51039 - BOOTPROTO not being written to ifcfg-ethx at all if Protocol tab is not accessed when building interface
Summary: BOOTPROTO not being written to ifcfg-ethx at all if Protocol tab is not acces...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-06 20:30 UTC by Panic
Modified: 2015-03-05 01:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-06 22:49:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Panic 2001-08-06 20:30:55 UTC
Description of Problem:

When configuring an ethernet interface through neat, there are three tabs
available to Add your configuration.  One of those tabs is Protocol, where
you can set whether or not DHCP is active, etc.  If this tab is not
accessed during the configuration of the interface, the BOOTPROTO setting
is not set all all in the ifcfg-ethx file, resulting in an interface that
returns OK on startup, but doesn't actually start.  If you try to start it
from the command line, it exits 0 and returns nothing at all because of the
missing entry.

How Reproducible:

Always

Steps to Reproduce:
1. Create an interface with neat's Add functionality, avoiding the Protocol
tab.
2. Exit neat to write the configuration
3. Note that the ifcfg-ethx file does not have a BOOTPROTO entry.

Actual Results:

missing BOOTPROTO entry

Expected Results:

The default in the tab is DHCP, would be okay to write that as a default.

Additional Information:

Comment 1 Glen Foster 2001-08-06 22:49:01 UTC
This defect is considered MUST-FIX for Fairfax

Comment 2 Phil Knirsch 2001-08-07 11:42:16 UTC
Fixed in CVS.


Note You need to log in before you can comment on or make changes to this bug.