Bug 510390 - Transifex does not handle all Serbian Latin files
Transifex does not handle all Serbian Latin files
Status: CLOSED NEXTRELEASE
Product: Fedora Localization
Classification: Fedora
Component: Website (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Dimitris Glezos
Diego Búrigo Zacarão
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-08 19:00 EDT by Miloš Komarčević
Modified: 2009-07-13 08:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-13 08:07:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloš Komarčević 2009-07-08 19:00:02 EDT
There seem to be a lot of Serbian Latin (sr@latin) files missing in the stats, e.g.:

https://translate.fedoraproject.org/languages/sr%40latin/collection/fedora/fedora-12/

even though they do exist, for example in anaconda:

https://translate.fedoraproject.org/projects/anaconda/master/

File filter matching problem?
Comment 1 Diego Búrigo Zacarão 2009-07-13 08:07:22 EDT
I've fixed it in 0.6 release of Transifex to handle it automatically.

The problem was related to the fact that the POFiles could not find if a new language was added to the system. In 0.6 in every checkout, case the POFile does not have a Language already, it looks for it.

sr@latin wasn't in the list for 0.5, as far as I remember. That's why some POFiles were not 'connected' to it. Those ones that are, it's probably because they were put in the system after we add sr@latin or the cache of them were cleaned.

Anyway, For a quick fix I just deleted all the sr@latin POfiles with Language=None from the database. That would be fixed in the next time that Transifex updates the stats. We have a cron job that does it 4 times per day.

I'm closing it as fixed. Feel free to reopen it in case you thing that something is still wrong.

Thank you

PS: We are releasing 0.7 soon, so it's not worth to upgrade to 0.6 right now.

Note You need to log in before you can comment on or make changes to this bug.